2

I've installed Ubuntu 18.04 on a new build computer (with a beautiful HD screen) but all I can get out of my GPU is a low resolution desktop. I have spent many days unsuccessfully trying to install NVIDIA drivers to get the full HD experience and am hoping if anyone exists who can help they'll be here!

The build:

Motherboard: Asus X399-A  
CPU: AMD Ryzen Threadripper 2970WX Processor  
GPU: Tried both a Gigabyte GTX 1050Ti and an ASUS GTX 1650

What happens:

If I boot with nouveau.modeset=0 or nomodeset in the Linux line at the GRUB stage I can get to a low-resolution desktop that works nicely. However it runs with LLVMpipe as the graphics driver and doesn't seem to let me change the screen resolution.

I have tried installing one-by-one a whole bunch of NVIDIA drivers, both those that ship with Ubuntu and those from the PPA repository. I've tried at least 440, 435, 430, 410, 390, 340 and got the same problem every time:

When I try to boot with an NVIDIA driver installed I briefly get shown the following:

WARNING: Failed to connect to lvmetad.   
Falling back to device scanning. Volume group "ubuntu-vg" not found  
Cannot process volume group ubuntu-vg  
[Then the above 3 lines again]  
/dev/mapper/ubuntu--vg-root: recovering journal  
/dev/mapper/ubuntu--vg-root: Clearing orphaned inode 5508628 [lists uid, gid, mode, size]  
/dev/mapper/ubuntu--vg-root: Clearing orphaned inode 13765684 [lists uid, gid, mode, size]  
/dev/mapper/ubuntu--vg-root: clean, 189374/14557184 files, 2762959/58221568 blocks 

Then the screen goes black and shows me the HDMI source banner as if it's lost signal.

What I've tried

I've updated the BIOS and tried installing each of the above drivers, both via the NVIDIA website and via command line. In between installs I've tried wiping the entire SSD and reinstalling Ubuntu 18.04, I've tried going into the command line (via recovery mode, then mounting the root with the networking option) and using sudo apt-get purge nvidia* to uninstall previous drivers, I've tried the GUI option to change to proprietary drivers, and I've tried sudo nvidia-drivers autoinstall. It doesn't make any difference, I still get the above error and a black screen.

In exasperation I've already returned my original Gigabyte GPU and got an Asus one instead, thinking, perhaps, the Asus motherboard might be happier with it (a really long shot, I know, but I seem to have tried everything else). Perhaps unsurprisingly, no difference.

The error message made me think twice about installing Ubuntu with LVM on my SSD. But when I try to do a standard install without LVM I don't even get to the pre-boot options page before I get the black screen.

I also tried the nvidia-xconfig strategy here Black screen with nVidia drivers on ubuntu and I still get exactly the same error and black screen.

My plea for help

This is my first time building a computer and first time playing with Linux. It's very possible that I've done something stupid so please don't hold back or assume any level of knowledge. The reason I wasn't scared to jump in is how amazed I was with the helpfulness of the Ubuntu community so thank you in advance anyone who can help!

9
  • 2
    Have you updated the BIOS on your motherboard? This is especially important for the newer AMD chipset boards, such as yours. Mar 3, 2020 at 18:45
  • 1
    Don't lose hope, I use a GTX 1050 Ti on 18.04 and it works well. I use the 390 drivers. Mar 3, 2020 at 19:48
  • I forgot to mention that I'd also updated the BIOS, I've edited that in. Thanks for the hope - I'll focus on the 390 drivers and let you know how it goes.
    – Saboten
    Mar 4, 2020 at 8:07
  • @OrganicMarble no luck I'm afraid. Whether it's the shipped driver 390 or the PPA one, I can't get off of llmvpipe. running nvidia-smi tells me that NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
    – Saboten
    Mar 4, 2020 at 9:45
  • 1
    Is Secure Boot disabled? Mar 4, 2020 at 13:57

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.