2

Sorry if this is a dumb question - I'm completely new when it comes to using Lubuntu or any similar system for that matter. I installed Lubuntu onto my old ASUS eee PC 900 off of an SD card. I tried it first as a Live USB and it worked fine - no display issues, preformed as I was expecting.

Then I installed it using the installer the Live USB had on the desktop. After that, the screen was snapped to a 800x600 resolution, though the screen (the on-board, connected screen - I don't have nor need a second monitor for this) is 1024x600. It displays the desktop fine, otherwise.

When I open Preferences> Monitor Settings, it shows that the "Laptop LCD Monitor" is detected, but the option to "Turn On" is both unchecked and grayed out, and the Resolution and Refresh Rate are set to "Auto". Furthermore, if I try to change either or both the Resolution and the Refresh Rate and click "Apply", an error comes up saying "You cannot turn off all monitors. Otherwise, you will not be able to turn them on again since this tool is not accessible without monitor."

This is actually the second time I installed Lubuntu on this machine - the first time, I ran into an issue where after the first reboot it failed to boot properly. I reloaded the Live USB and installed again from there. (Before trying Lubuntu, I had Linux Mint on there but it was egregiously slow and prone to overheating. The previous Mint installation and the XP one before it are gone completely.)

I have found one quick-fix workaround to this. Entering xrandr -s 1024x600 will set the resolution to the correct size. It also changes the Monitor Settings; the "Turn On" box is now checked (though still grayed out), and not only is the Resolution set to the correct size, but the refresh rate also changes from "Auto" to "59.92". But this resets after a Reboot or Shut Down and goes back to the 800x600 size when it next starts up.

Lubuntu works fine, otherwise (barring some issues with the battery gauge taking too long to update, and the brightness control shutting off the screen if I go too low). I've tried looking up solutions for the past few days straight, mostly getting answers that don't apply to my situation.

Thank you in advance!

Specifications:

ASUS EEE PC 900
Ram: 1GB  
CPU: Intel Celeron M 900 MHz
Graphics: Intel GMA 900 GPU
Storage: 16GB SSD
OS: Lubuntu 18.04.4 Desktop 32-bit

P.S: In the System Profiler and Benchmark, it does list the Graphics as "Unknown", both before and after the quick fix. If there's any other needed info please let me know!

EDIT 1: At the boot select, the only option is "HDD: PM-ASUS-JM S41 SSD". After selecting that option, I can press ESC to get into GRUB2. The top option is "Ubuntu", and after selecting that and pressing e, I edited the setparams to the best of my ability?

I tried editing the first gfxmode line to look exactly like gfxmode=$…linux. That didn't work, threw up an error and I quickly hit Esc and tried again. This time I left the top gfxmode line alone so it looks like gfxmode $linux_gfx_mode. I then hit enter after that, and pressed Space until the cursor lined up with the previous line and proceeded to type in gfxmode=1024*600. Booted it up, didn't seem to do anything, so I shut it back down and went in again.

This time I got back into GRUB2. The changes I made were gone, and looking at the gfxmode line I realized that there's an = missing, maybe? I added it in so the upper line now said gfxmode=$linux_gfx_mode. Then I added the second line, gfxmode=1024*600 again in the same way as before and hit f10.

Upon restart, the resolution is much much lower. It's extremely zoomed in, though the effective screen is now wider than it was before. It still doesn't utilize the entire screen though, and Monitor Settings still is unresponsive as before.

  • 1
    There are no dumb questions here. You phrased the circumstances very concisely. – K7AAY Mar 2 at 18:33
0

Restart your eee,
press the Esc key to enter the GRUB2 Bootloader Menu
highlight the top item then press e

Now, edit setparams

gfxmode=$…linux
gfxmode=1024*600

If that resolves the issue, then edit GRUB2's configuration to make the change permanent.

If not, reboot, and remove the gfxmodes line entirely.

Solution based on https://askubuntu.com/a/991214/197910

|improve this answer|||||
  • 1
    Thanks for the quick response! I tried holding down Esc when booting up, but the Bootloader it took me to looks nothing like GRUB2. It's a blue window, the top saying "Please select boot device:" with a list beneath it (mine currently only showing the HDD). The HDD is auto selected, and pressing e doesn't seem to do anything. My only options seem to be moving up or down and hitting Enter to select the boot device. Could this be my underlying issue? Not having the correct bootloader? – Anachronism42 Mar 2 at 18:47
  • What are your choices in the list below? After you pick the HDD, can you then {Esc} into GRUB? Your responses, idelaly, even the reply comment above, should go in the Question, and that's done with edit. We want all the facts in the Question, and to use Comments as a one way channel from the Nerd Herd here to you. – K7AAY Mar 2 at 18:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.