0

I have created a Samba share with Ubuntu 19.10 the most easy way: In the files browser, right-click on the folder I want to share, select "Local network share", then at first time a prompt will ask to install the Samba (v4.10.7) packages. Similar to the command line:

sudo apt install samba samba-common

Afterwards, I set up a Samba password for my main user account with this command:

sudo smbpasswd -a {myusername}

Now I can successfully access the shared folder from another Ubuntu or Windows device with my user name and the given Samba password.

However I fail to access using a few years old network media player. It does show the shared network folder and prompt for username and password when trying to connect, but then fails with a simple "cannot access network folder" error.

If I can access the Samba share with a modern computer but not with an older device, what might be the problem?

I had set up Samba shares with older Ubuntu version 16.04 (Samba v3.x) the same way and that still works with my network player. Maybe an old authentication mode, which I would have to enable with Samba v4?

  • 1
    Wannacry happened in 2017, which didn't impact Linux/Ubuntu, but did badly impact Microsoft, so they made changes that Linux followed. Ubuntu 16.04 was before the wannacry issues, which is why it worked there, later releases (post-WannaCry) need to be told specifically to work at the lower security level now to be msft compatible, ie. you likely need to specify a ,vers=1.0 – guiverc Mar 2 at 0:30
1
Maybe an old authentication mode, which I would have to enable with Samba v4?

That may very well be the issue. You can try editing /etc/samba/smb.conf and adding the following in the [global] section - like right under workgroup = WORKGROUP:

lanman auth = yes
ntlm auth = yes

THen restarting smbd:

sudo service smbd restart
| improve this answer | |
  • Great! This almost did it. I also had to add the line server min protocol = NT1, now it is working again. :) – w-sky Jul 4 at 2:32
  • Also, for the other way round I needed client min protocol = NT1 to be able to access the shares of the network media player with my Ubuntu notebook. – w-sky Jul 4 at 2:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.