0

A friend asked me to wipe/format a 2TB external HDD. It just doesn't work.

With lsblk -l I can see the disk which is formatted in NTFS and mounted as /dev/sdg1.

I tried mkfs.fat /dev/sdg1, resulting in mkfs.fat: /dev/sdg1 contains a mounted filesystem.

sudo umount /dev/sdg just takes forever and nothing happens.

Then I tried dd if=/dev/zero of=/dev/sdg1 bs=1M, but again, nothing happens. No output; all I can do is close the terminal window and terminate the process.

Finally I entered sudo gparted. The program keeps loading until I plug out the external HDD, only then it shows my computer's SSD.

I've never had this problem with any hard drive before. Any ideas?

2
  • 1
    Have you looked at it's health, ie. using the drive's SMART technology. Is the drive healthy? help.ubuntu.com/community/Smartmontools
    – guiverc
    Mar 1, 2020 at 1:16
  • Apparently it doesn't support SMART. All I get is: /dev/sdg: Unknown USB bridge [0x0bc2:0xab26 (0x108)] Please specify device type with the -d option.
    – Malory
    Mar 1, 2020 at 9:03

1 Answer 1

1

You must sudo umount /dev/sdg1 before you can change the disk's structure.

While the disk (or any partition) is mounted, the disk structure exists in two places: On the disk; and in kernel memory.

While the disk is NOT mounted, the structure information exists only on the disk.

A simple user program (gparted), even if running as root shoud NOT manipulate the disk structure in kernel memory. It doesn't know how (for every OS/kernel/filesystem version), there are synchronizations issues, etc.

Therefore, the umount /dev/sdg1 is required before you attack the disk with gparted.

`

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.