1

I just bought a Dell optiplex SFF machine with Ubuntu Linux 18.4 preinstalled. Through a misconfiguration from my side, the machine was shipped with two Network cards without Wifi capabilities. So I bought the:ASUS WLAN-AX PCIe Adapter PCE-AX3000 with Bluetooth 5.0 , replaced the extra non-Wifi card with the above and tried to get it up running but didn't succeed up to now.

I went through many articles but couldn't get the card up running and as I am quite new to linux I don't know what else to check. I was hoping that someone knows what to do in order to have it working.

I provided below some outputs that I thought could be helpful.

The UNCLAIMED Network adapter is the one that is making troubles.

lshw -c network
WARNING: you should run this program as super-user.
  *-network UNCLAIMED       
       description: Network controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 1a
       width: 64 bits
       clock: 33MHz
       capabilities: cap_list
       configuration: latency=0
       resources: memory:a4200000-a4203fff
  *-network
       description: Ethernet interface
       product: Ethernet Connection (7) I219-LM
       vendor: Intel Corporation
       physical id: 1f.6
       bus info: pci@0000:00:1f.6
       logical name: eno1
       version: 10
       serial: c8:f7:50:f7:a7:a3
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=0.5-4 ip=192.168.100.115 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:138 memory:a4400000-a441ffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

The first one is the driver that the wifi card came with on a separate CD-ROM and as it is already in the firmware folder I assume it has been properly installed.

(base) bdw@DELL-bdw:/lib/firmware$ ls | grep iwlwifi-cc
iwlwifi-cc-a0-46.ucode
iwlwifi-cc-a0-48.ucode

kernel


(base) bdw@DELL-bdw:/$ uname -a
Linux DELL-bdw 4.15.0-1073-oem #83-Ubuntu SMP Mon Feb 17 11:21:18 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
1
  • Please edit your question to add the result of the terminal command: lspci -nnk | grep 0280 -A3 We suspect that your very new wireless card is not yet supported in kernel version 4.15-xx. Welcome to Ask Ubuntu.
    – chili555
    Feb 29, 2020 at 16:27

1 Answer 1

0

Upgrading kernel to 5.3 should fix the issue

sudo apt install linux-generic-hwe-18.04

But OEM drivers if any may not build.

1
  • Upgrading the kernel solved the issue. @Pilot6Thanks a lot for the advice.
    – westpoint
    Feb 29, 2020 at 18:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.