So I have an HP Spectre 15, dual-booting Xubuntu 19.10/Windows 10, and the HP USB-C Universal Dock. The dock works perfectly, all the ports work, network and USB, and the display connected to it works, it's even hot-pluggable so when I disconnect and reconnect to the dock everything works as it should.

My only problem is that if the dock is plugged in during boot it will hang at the boot loader. Peripherals connected to the dock do not work, and nor do the inbuilt keyboard and touchpad. I've tried booting with grub and ReFind as the bootloader but both experience the same problem. My preference is ReFind but at the moment I just want it working.

I couldn't find anything remotely similar to this problem when searching and I'm not sure what to do, so I've resorted to posting here. If log information would be helpful I can post that, but I'm not sure what logs to look at to be honest.

Any help would be appreciated.

1 Answer 1


So I figured it out!

The problem wasn't with the dock at all, it was one of the USBs I had plugged into my monitor's USB hub that was plugged into my dock. Just for anyone wondering how I figured this out I unplugged everything from the dock then booted the laptop with the dock plugged in; it worked. I then plugged in 1 cable, and booted again. I repeated this until I found the offending cable; the keyboard.

Once I figured this out I followed the advice from this post: Grub freezes when logitech unifying receiver plugged in

Which was to enable legacy support in my BIOS by going into the BIOS then System Configuration -> Boot Options -> Legacy Support -> Enabled.

This has resolved the problem and now the bootloader doesn't freeze.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.