I'm using Ubuntu 11.10 on Dell Inspiron mini 1018. I disabled the wireless network and it does not enable again. It reports that wireless is disabled by hardware switch. Pressing the hardware switch and any combinations on the keyboard has no response. Neither does sudo rfkill unblock all have any effect.

Rfkill list gives the following results:

0: hci0 bluetooth ...........  
1: dell-wifi:wireless lan
  soft blocked yes
  hard blocked yes  
2: dell bluetooth ...........  
3: phy0; wireless lan
  soft blockes no
  hard blocked ye

sudo iwconfig wlan0 gives:

ieee 802.11bgn essid off/any
mode:managed access point:not associated tx-power=off
retry long limit:7 rts thr=2347 b fragment thr:off
power management:on

sudo lshw -c network returns:

*network DISABLED

ugh... that sounds like a BIOS bug. You can try updating your firmware in hopes that they might have fixed it for Linux, or, if you still have Windows installed, boot into it, and from there toggle the switches until the Wifi comes back. Happened to me once with an Acer laptop where I was playing with rfkill and the only way I could "unflip" that bit was by booting into Windows.

  • I don't think the BIOS handles wireless adapters in most cases. – titaniumtux May 20 '12 at 17:20
  • It's really ACPI, but trying to explain that to most people falls flat so I just combine the two and say "BIOS". ACPI owns all the hotkey controls, what rfkill uses (usually, or it's SMI) and managing the state of all these devices. As soon as the OP disabled the device, it called through ACPI. There are no assurances, that a the "turn off" function for a device is just as effective as the "turn on" function. The fwts suite is good at profiling your firmware and showing you exactly how broken it is which can assist vendors in finding the root cause. – ppetraki May 21 '12 at 12:38
  • @ppetraki: So what can you do if the BIOS is already latest version, and you don't have Windows? I got an Acer Travelmate, and I remember this Windows trick working, but got no Win anymore. :-( – Christoph Jul 21 '12 at 8:43
  • @Christoph: unfortunately, you go install windows. Having an external USB HDD around is good for this. It's obnoxious I know but since the vendor hasn't bothered to spec how it works you're left waiting for someone to reverse engineer it. You could try installing the latest kernel, new support might have been added. – ppetraki Aug 1 '12 at 13:29
  • @ppetraki: actually, in the meantime I managed to solve my problem (without windows): askubuntu.com/questions/166328/… – Christoph Aug 1 '12 at 13:56

Try sudo ifconfig wlan0 down, then sudo ifconfig wlan0 up (if necessary). If that doesn't work, try killing the session or even rebooting.

Hope that works, usually does the trick for me in those sticky wifi situations (and only really useful command I've found in wifi troubleshooting documentation that isn't related to driver configuration).


Just tried the tip from another forum. I got an acer one ZG5 running Ubuntu 11.04. Had the wirelss disabled by hardware switch showing in the wireless drop-down. Tried booting Ubuntu from USB and still had same problem. Simply had to remove battery and put back in. Don't know why it works but it did for me and others quoted.


Symptoms: This problem started to occur after I removed the battery from my computer (Toshiba laptop) running Ubuntu 11.10 and reinserted it. Suddenly I noticed the messages "device not ready" and "wireless is disabled by hardware switch".

Solution: To solve the problem simply:

  1. Shutdown the computer
  2. Take out the battery and reinsert it

In this case the solution is in the cause of the problem! Try if this works for you!


this was also troubling me a lot on a Lenovo G570.

Here's what I did:

  • Update the BIOS
  • Take out the battery and place it in again
  • Boot into pre-installed Windows 7
  • Enable the wifi functionality:
    • get the dialogue up by Fn+F5
    • verify that networks are there
  • reboot in Ubuntu --> all is good!

Here are the modules:

lspci -nnk | grep -i net -A2
01:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8152 v2.0 Fast Ethernet [1969:2062] (rev c1)
    Subsystem: Lenovo Device [17aa:3979]
    Kernel driver in use: atl1c
02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
    Subsystem: Broadcom Corporation Device [14e4:051b]
    Kernel driver in use: bcma-pci-bridge

lsmod | egrep 'ssb|wl|b43|b44|ndis|bcma|brcm|brcmsmac|broad|brm'
brcmsmac              550698  0 
cordic                 12574  1 brcmsmac
brcmutil               14755  1 brcmsmac
bcma                   41051  1 brcmsmac
mac80211              606457  1 brcmsmac
cfg80211              510937  2 brcmsmac,mac80211

Thanks to all who posted their hints and suggestions above!!


If you dual boot Windows and Ubuntu, then your Windows installation may have changed some settings. Just boot into Windows, re-enable wireless there, then the wireless should be working fine in Ubuntu


I found out by trial and error that the Wifi hardware switch on my Dell XPS 17 L702X is not Fn+F2, as implied by the keyboard icon (and works in Windows), but actually Fn+Alt+F2 in Ubuntu. It might work for your Dell too.


Had some issue except that phy0 was not blocked. I'm blacklisted ideapad_laptop module and now seems to all works fine!

echo blacklist ideapad_laptop > /etc/modprobe.d/bad_rfkill.conf
depmod -ae
update-initramfs -u

And rebooted. What i disabled with removing this module except wireless interface?


I had this same problem with a Dell M3800 running Ubuntu 14.04, and found the following bug report https://bugzilla.kernel.org/show_bug.cgi?id=93341 helpful.

I put my computer in suspend mode, then woke it back up, and the 'hard block' went away, allowing me to re-enable the wifi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.