2

I have bought a Lenovo V130 with a graphic card AMD Radeon 530 2G. I put an Ubuntu 18.04 on it, updated, upgraded, then installed the driver from the AMD site (amdgpu-pro-18.20-673703-ubuntu-18.04). Of course, I met the login loop as it did crash with the integrated Intel Graphics. I used the

amdgpu-pro-uninstall

command, then I could use the graphic mode again. Since then, when I wanted to reinstall the package, I get the error massage:

[sudo] m jelszava: 
deb [ trusted=yes ] file:/var/opt/amdgpu-pro-local/ ./
Letöltés:1 file:/var/opt/amdgpu-pro-local ./ InRelease
Mellőz:1 file:/var/opt/amdgpu-pro-local ./ InRelease
Letöltés:2 file:/var/opt/amdgpu-pro-local ./ Release [816 B]
Letöltés:2 file:/var/opt/amdgpu-pro-local ./ Release [816 B]
Letöltés:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg
Mellőz:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg
Találat:4 http://repo.jztkft.hu/ubuntu bionic InRelease
Találat:5 http://repo.jztkft.hu/ubuntu bionic-updates InRelease
Találat:6 http://repo.jztkft.hu/ubuntu bionic-backports InRelease
Találat:7 http://repo.jztkft.hu/ubuntu bionic-security InRelease
Találat:8 http://archive.canonical.com/ubuntu bionic InRelease
Csomaglisták olvasása... Kész 
Package: *amdgpu*
Pin: release o=AMD
Pin: version *-673703
Pin-Priority: 1000

Package: *amdgpu*:i386
Pin: release o=AMD
Pin: version *-673703
Pin-Priority: 1000

Csomaglisták olvasása... Kész
Függőségi fa építése       
Állapotinformációk olvasása... Kész
E: Ez a csomag nem található: xserver-xorg-video-modesetting-amdgpu-pro

Sorry, dont know how to set to English. Letöltés = Download Mellőz= Skip or Dispense Találat= Found

At the end it says: This package cannot be found: xserver-xorg-video-modesetting-amdgpu-pro

Could you please help me?

Thanks!

1
  • Nope, 18.04 of course, but I will edit it. – Gszives Feb 27 '20 at 22:00
1

Update

I deleted the amd folders from var/opt and usr/bin. After that, I was able to install the driver, now the '17 version with --px. Everything worked well, there was not any login loop or black screen.

Still, in system information Ubuntu sees the Intel HD Graphics and its driver. Can I check if there is a Radeon Card in my computer without disassembing it?

1

So I worked it out.

Did these steps

$ sudo amdgpu-pro-uninstall

$ sudo apt-get autoremove amdgpu*

Manually deleted all amdgpu dependencies from var/opt and usr/bin

$ sudo apt update

Then I restarted the computer - for the sake of the piece of my hobby-linux soul - and followed the instructions on https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers I think I should have started here.

$ sudo add-apt-repository ppa:oibaf/graphics-drivers

$ sudo apt update && sudo apt upgrade 

Restart again.

Since then, sys info says Mesa is running on my Ubuntu, instead of the Intel driver. Not really sure that it uses the Radeon card, though. How could I check it?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.