0

I have no Ethernet. My router and cable are ok, checked. During installation it worked fine, To another pc, but now cannot connect... I have tried some things neither works. I installed the OS in another motherboard!!! In terminal:

sudo lshw -class network -short

Output:

enp2s5 network 88E80001 Gigabit Ethernet Cont

Seems that driver is ok

I have edited with sudo the /etc/NetworkManager/NetworkManager.conf file and changed the managed=false to managed=true

Also, I have edited the /etc/netplan/*.yaml file adding the line renderer: NetworkManager

Both actions are described in No wired connection - Wired unmanaged ubuntu 18.04

But no effect. Could it be a hardware problem? The PC was many years locked...

The desktop icon shows that there is no connection whether the Ethernet cable is plugged in or not. Clicking the icon reveals 2+1 ethernet connections. The 1st one says used 10 days before with the name netplan-enp2s5 the second one says never used before with the name Wired connection 1 and the third one is the one I created also never used before with name Ethernet connection 1 and manually configured with parameters: address=192.168.1.100, mask=24, Gateway=192.168.1.1 (automatic DHCP)

4
  • @guiverc My Ubuntu version is : Ubuntu 18.04 LTS
    – mela
    Feb 27 '20 at 22:05
  • @Nmath Things that i tried: -Restart NetworkManager -Manually config ethernet connection -Reset skge driver with command modprobe -netplan apply and edit its file *.yaml from 'rendered: networkd' to 'rendered : NetworkManager'
    – mela
    Feb 27 '20 at 22:15
  • What shows up in NetworkManager when you click on the icon on your dash? What shows up in NetworkManager when you plug the ethernet cable in?
    – mchid
    Feb 29 '20 at 1:30
  • Also, I assume it is a typo in your question but the line should be managed=true and not manage=true Additionally, sometimes it helps to delete all of your old network connections when you switch Ubuntu to a new computer. You can do this by deleting the files in /etc/NetworkManager/system-connections/* and then restarting NetworkManager.
    – mchid
    Feb 29 '20 at 1:33
1

Since it worked during the installation, you should be able to install the drivers from the iso. So, if you have access to the original iso file you used for installation, you can install the drivers from there.

First, transfer the iso file to your Ubuntu computer user's home directory.

Next, run the following commands (this assumes that you did not change the original name of the iso file):

sudo mkdir /media/cdrom
cd
sudo mount -o loop ubuntu-* /media/cdrom

Now, search for "software and updates" in your applications and under the "Ubuntu Software" tab, scroll down and click the box to place a check in the box for "CDrom with Ubuntu" option.

Enter your password when prompted and this should reload your software sources.

Finally, select the "Additional Drivers" tab and select your wireless driver and then click "Apply Changes" to install the driver.

This was loosely based on an itsfoss.com article by Abhishek Prakash.

6
  • The installation was in another motherboard ... the bootable usb is now corrupted...
    – mela
    Feb 28 '20 at 17:26
  • @mela Not the USB but the iso file used to make the USB. You just need to download the 18.04 iso file and then transfer that file to your user's home directory on your Ubuntu computer.
    – mchid
    Feb 29 '20 at 1:12
  • @mela Okay, I see that the installation was to different hardware. I will leave this answer here for now in case it might help someone else. In the mean time, please include what happens when you click on the network icon on your desktop. Does it show a network? If so, does it fail to connect or are you not able to use the internet after it connects? Also, please include how you "manually configured" the wired connection as there are many different ways to do this and this may be part of the problem. Thanks!
    – mchid
    Feb 29 '20 at 1:37
  • @mela One last thing, please run the following command and include the output in the question. Thanks! cat /etc/network/interfaces
    – mchid
    Feb 29 '20 at 1:41
  • When i run the command cat /etc/network/interfaces i get the following: #ifupdown has been replaced by netplan(5) on this system. See /etc/netplan for current configuration #To re-enable ifupdown on this system, you can run: sudo apt install ifupdown !-- the suggestion from OS is unable due to no internet connectivity, also in netplan there is the *.yaml file which does not say much--
    – mela
    Mar 2 '20 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.