12

I am using Ubuntu 19.10 with the new Inspiron from Dell - 7590 (model info from Arch Linux)

The microphone does not work, but speakers do. I tried anything - building kernel 5.5.6 and updating alsa to 1.2.1, but it does not seem to help. The integrated microphone as well as the 3.5mm generally do not work, but there seems to be activity in pavucontrol (I think this is white noise). Also there is nothing shown as input (when I go to settings -> sound), but I can see something in pavucontrol

My multimedia controller is:

00:1f.3 Multimedia audio controller: Intel Corporation Cannon Lake PCH cAVS (rev 10)
    DeviceName: Onboard - Sound
    Subsystem: Dell Cannon Lake PCH cAVS
    Flags: bus master, fast devsel, latency 32, IRQ 177
    Memory at ed318000 (64-bit, non-prefetchable) [size=16K]
    Memory at ed100000 (64-bit, non-prefetchable) [size=1M]
    Capabilities: [50] Power Management version 3
    Capabilities: [80] Vendor Specific Information: Len=14 <?>
    Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel, snd_soc_skl, sof_pci_dev

No input devices show by default on clean install of Ubuntu. I tried 18.04 (LTS) but the result is the same, so I switched back to 19.10. When I run pavucontrol it shows this:

enter image description here

I can see noise and that the mic is recording something (but I cannot control it from the sound settings) but it does no react to my voice.

Output from cat /proc/asound/card0/codec* | grep Codec:

Codec: Realtek ALC3254
Codec: Intel Kabylake HDMI

I hope someone can help me out here, I would be really grateful. Thanks in advance!

Output from lshw | grep -n -i -A 14 -B 10 audio :

312-             product: Intel Corporation
313-             vendor: Intel Corporation
314-             physical id: 1f
315-             bus info: pci@0000:00:1f.0
316-             version: 10
317-             width: 32 bits
318-             clock: 33MHz
319-             capabilities: isa bus_master
320-             configuration: latency=0
321-        *-multimedia
322:             description: Multimedia audio controller
323-             product: Cannon Lake PCH cAVS
324-             vendor: Intel Corporation
325-             physical id: 1f.3
326-             bus info: pci@0000:00:1f.3
327-             version: 10
328-             width: 64 bits
329-             clock: 33MHz
330-             capabilities: bus_master cap_list
331-             configuration: driver=snd_hda_intel latency=32
332-             resources: irq:177 memory:ed318000-ed31bfff memory:ed100000-ed1fffff
333-        *-serial:2
334-             description: SMBus
335-             product: Cannon Lake PCH SMBus Controller
336-             vendor: Intel Corporation
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

Output from lspci | grep -n -i -A 10 -B 1 audio:

17-00:1f.0 ISA bridge: Intel Corporation Device a30d (rev 10)
18:00:1f.3 Multimedia audio controller: Intel Corporation Cannon Lake PCH cAVS (rev 10)
19-00:1f.4 SMBus: Intel Corporation Cannon Lake PCH SMBus Controller (rev 10)
20-00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller (rev 10)
21-01:00.0 3D controller: NVIDIA Corporation Device 1f91 (rev a1)
22-02:00.0 PCI bridge: Intel Corporation JHL6340 Thunderbolt 3 Bridge (C step) [Alpine Ridge 2C 2016] (rev 02)
23-03:00.0 PCI bridge: Intel Corporation JHL6340 Thunderbolt 3 Bridge (C step) [Alpine Ridge 2C 2016] (rev 02)
24-03:01.0 PCI bridge: Intel Corporation JHL6340 Thunderbolt 3 Bridge (C step) [Alpine Ridge 2C 2016] (rev 02)
25-03:02.0 PCI bridge: Intel Corporation JHL6340 Thunderbolt 3 Bridge (C step) [Alpine Ridge 2C 2016] (rev 02)
26-04:00.0 System peripheral: Intel Corporation JHL6340 Thunderbolt 3 NHI (C step) [Alpine Ridge 2C 2016] (rev 02)
27-3a:00.0 USB controller: Intel Corporation JHL6340 Thunderbolt 3 USB 3.1 Controller (C step) [Alpine Ridge 2C 2016] (rev 02)
28-3b:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd Device a809

Update: seems the mic now works under Archlinux: https://wiki.archlinux.org/index.php/Dell_Inspiron_15_(7590)

Update #2: With a little help from sof developers, I think I can get my mic (as well the one from many other dell laptops) working - https://github.com/thesofproject/sof/issues/2502

  • What happens if you plug an external microphone? What do you see in tabs Recording and Configuration? What do you see with pavumeter, arecord -l, alsamixer? – sancho.s ReinstateMonicaCellio Mar 1 at 11:32
  • Еxternal mic with 3.5mm not working, only usb and bluetooth – Кристиян Кацаров Mar 1 at 11:33
  • Then, what do you see with the two working external mics? What do you see with the mentioned commands/tabs? What do you see with lshw | grep -n -i -A 14 -B 10 audio, lspci | grep -n -i -A 10 -B 1 audio? – sancho.s ReinstateMonicaCellio Mar 1 at 11:44
  • I cannot post the output here, but it shows 2 things, *-multimedia and *-serial:2 which is Cannon Lake PCH SMBus Controller (this is via bluetooth headset) – Кристиян Кацаров Mar 1 at 11:50
  • usb-2.00 audio-control appears when usb c headset connected – Кристиян Кацаров Mar 1 at 11:51
3
+350

You might try an OEM kernel image (or the linux-oem package, there is also a tools and modules package) as these sometimes have better support of OEM Hardware (especially Laptops) and as far as I recall, Dell is contributing there or actively supporting it.

#should install everthing basic you need
sudo apt-get install linux-oem
#or for a >= 5.0 Kernel
sudo apt-get install linux-oem-osp1
#Might want to install oem tools but try it without first if they are not automatically installed

If the OEM-Kernel does not help you you might try checking the differences between your 19.10 and 18.04 manufacturer image or if the problem still persists when booted from a live or USB stick using the manufacturer image.

If the problem persists with the officially supported image, then the driver really might not support using it the way you want.

OEM Kernel Image

Certified HW Ubuntu Inspiron 7590

| improve this answer | |
  • Thanks, I will try this! – Кристиян Кацаров Mar 5 at 8:56
  • Ah and don't forget to check that you actually booted the oem-kernel and the bootloader did not select the generic image – Ritualmaster Mar 5 at 9:00
  • Is there an oem ubuntu .iso image to install? Currently I am using Pop.OS 19.10 which is ubuntu 19.10 based – Кристиян Кацаров Mar 5 at 9:34
  • for the above commands to test you can try on an already installed one. If you want to try the Dell recovery image you might try: dell.com/support/home/uk/en/ukbsdt1/drivers/osiso/linux – Ritualmaster Mar 5 at 10:27
  • Or you just get a naked ubuntu 18.04 (iso fro the website) and prepare a stick with it and install the oem stuff. Otherwise I do not know. – Ritualmaster Mar 5 at 10:28
1

Be sure to use an application that can record audio. See the message in Puva, recording tab. Try gnome-sound-recorder. You can find it in Synaptic. Also be sure that your web-browser is capable of recording.

| improve this answer | |
1
  1. First check the mic sound level. To check the sound level install alsamixer. To do that use following commands:

    **sudo apt-get install alsa-utils**
    
    **sudo apt-get install alsamixer**
    
  2. Once alsamixer is installed then run following command to run it

    **alsamixer**
    
  3. Then press F6(Function key to check the sound cards) and select appropriate sound card and press enter key.

  4. The screen will show volume level for Master, Speaker, Headphones and MIC (Depending on the system, this list may vary). Make sure MIC volume is not zero.

| improve this answer | |
  • Tried this, there is only one sound card and everything is up (not muted) – Кристиян Кацаров Mar 4 at 7:40
  • Did you try following commands? sudo alsa force-reload alsactl restore Then restart system. – YashTheRedDevil Mar 4 at 7:48
  • Yes, I don't think it has to do with alsa (I tried compiling it as well, updating the kernel, etc). 3.5mm jack not working as well (though mic via 3.5mm works with really bad quality) – Кристиян Кацаров Mar 4 at 7:51
  • I updated the question, it seems to be working with sof firmware under arxhlinux, how do I install it in ubuntu? – Кристиян Кацаров Mar 6 at 17:34
1

There is a way to fix this.

I have the same laptop and I'm also running 19.10. As the OP, I also managed to solve this problem. I'm writing this answer as a "how to" guide, just to help others having the same problem as we had. The oem kernel proposed by @Ritualmaster is tested and at least in my 7590+ubuntu19.10 configuration, is not working.

The problems:

  • The sound(speakers, line in-out, dmic) is fully working using sof, but the ucm configuration files needed are not in the master branch of the project nor in Ubuntu's installation.

  • Ubuntu's update to 5.3.0-42 kernel breaks sof causing failure to the sound system, leaving a DummyOutput device for sound output.

So I'll try to document the required steps for the solution:

1. Blacklist "snd-hda-intel" and "snd-soc-skl" modules in order to let the linux kernel to load the sof driver. The driver is already installed as it is part of the kernel since 5.2 (I think).

sudo touch /etc/modprobe.d/blacklist-snd.conf
sudo echo "blacklist snd-hda-intel" >> /etc/modprobe.d/blacklist-snd.conf
sudo echo "blacklist snd-soc-skl" >> /etc/modprobe.d/blacklist-snd.conf

2. Fetch the sound card configuration files from the sof project repository. This step requires git. So if you don't have it, install it via sudo apt install git. The configuration files are not in the master branch and so both the existence and the contents of them is not guaranteed. For that reason we will checkout the files exactly in the right version manually.

cd ~
git clone https://github.com/thesofproject/alsa-ucm-conf.git
cd alsa-ucm-conf
git checkout -b inspiron f083700
sudo cp -r ucm/sof-skl_hda_card /usr/share/alsa/ucm/

3. If you have installed the kernel update "5.3.0-42", you also have to make sure you are booting to the previous "5.3.0-40" version every time. One simple way for doing this is editing grub. Find /etc/default/grub and delete line GRUB_DEFAULT=0. Then add the lines below

GRUB_SAVEDEFAULT=true
GRUB_DEFAULT=saved

Now update grub and reboot

sudo update-grub
sudo reboot

4. Assuming you are using inspiron 7590 ;) make sure you press F1 when the dell logo appears while booting, in order to bring up the grub menu. From this menu select advanced and then 5.3.0-40. Bringing up the grub menu is not necessary every time, only once. In the previous step we have set grub default selection to "saved". That means it will continue to boot the last selected version from now on.

That's it. Hopefully the system will boot and the sound cart will be detected just fine.

For example in my pulseaudio volume control: enter image description here and enter image description here

Note 1: If mic level is still low, you can raise it in alsamixer.

Note 2: If there is a better way of selecting kernel to boot let me know.

Useful links:

| improve this answer | |
0

that's what worked for me: install sudo add-apt-repository ppa:kaihengfeng/fix-lp1869819 and put it

options snd-hda-intel dmic_detect=-2
options snd-hda-intel model=dell-headset-multi

into file /etc/modprobe.d/alsa-base.conf

It works for ubuntu 20.04 on Dell G3 3590!!!

| improve this answer | |
0

While hoo2's answer is not working for me, it helped me to find a solution.

I am running Ubuntu 20.04, on Dell Vostro 7590 with kernel version 5.6.0-1020-oem.

Here are the steps:

  1. Install SOF firmware and topology binaries:
git clone -b stable-v1.5.1 https://github.com/thesofproject/sof-bin.git
cd sof-bin
sudo ./go.sh
  1. Blacklist snd-hda-interl and snd-soc-skl by adding following lines to /etc/modprobe.d/alsa-base.conf:
blacklist snd-hda-intel
blacklist snd-soc-skl

Note that if you have some other changes to that file, it is good to revert them (e.g. remove options snd_hda_intel dmic_detect=0).

  1. Reboot
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.