0

I have 2 accounts, when I run the users app, only 1 of them shows up I't's been this way for some time now, the second account called jenkins was a system account. It worked fine for my purposes (local login only) until now. So I edited it to be not system, but it's still not showing up. Both my account and the jenkins account are "sudoers". So I am assuming they are in the admin group.

I guess the question is, what group must an account belong to to show up in the gui app, and more importantly, which group, to allow remote login. I know this is a stupid question, but it's asked out of frustration trying multiple suggestions on this board, then rebooting, and still being stuck with my jenkins account not being "visible" and also not allowing remote connections. Please tell me my question is stupid, but also tell me why exactly it is stupid, so I leanr from it; as I struggled with this years ago on ubuntu 14 or so as well, but I have 18 installed now.

/edit "Not showing up", is meaning when I use the finder and tap "user" and then open "Add users", and then use my password to unlock. It only shows my intiali user account "Conrad Braam" in there.

By "setting it to not system", basically I saw a note about editing /var/lib/AccountsService/users/jenkins and changed the line SystemAccount=true to SystemAccount=false but now I notice, that that change has reverted/not saved? Hmmm. Rebooting again.

I run id -u jenkins and I get a response 123 Which strikes me as unexpected or arbitrary. So I do need to set it to something > 1000, but something about the user files is still locked, I might just need help deleting or chown'ing the existing jenkins user files?

  • What do you mean by "when I run the users app" ? How did you "edit it to be not system" ? – Soren A Feb 26 at 13:52
  • question updated, I originally used commandline to create the account and also used sudo usermod -aG sudo jenkins to try remedy. I can log in locally interactive to that account. Just no showing up, so keen to learn a bit more. – Conrad B Feb 26 at 15:53
1

It's the numerical value of the UID rather than a specific group membership that determines whether a user account shows up in the Users & Groups dialog. I believe the threshold is UID >= 1000 but I have not verified this exhaustively.

To change a user's UID, you can use usermod ex.

sudo usermod -u 1005 jenkins

You will need to choose a suitable unique UID > 1000 based on the current user accounts on your system. Note that you may need to manually chown some files to make their ownership reflect the new UID, as explained in man usermod:

       The user's mailbox, and any files which the user owns and which are
       located in the user's home directory will have the file user ID
       changed automatically.

       The ownership of files outside of the user's home directory must be
       fixed manually.

You may wish to change the GID as well, to be consistent with the Debian 'User Private Group' paradigm.

| improve this answer | |
  • I rebooted, because I got a "usermod: user jenkins is currently used by process 1710" kinda error message. That did not help, killing the process just starts a /usr/bin/daemon --name=jenkins process instantly again. I suspect the UID i used is not unique. – Conrad B Feb 26 at 15:46
  • If you have process/services that are started automatically under this user, then you may need to drop into single-user mode / rescue.target in order to apply the change. – steeldriver Feb 26 at 15:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.