0

I have a hard drive from 2012, I would like the data off from it. I am trying to mount the devices, but I cant figure out the filesystem type. I have tried lsblk, file -s, and blkid, which havent told me anything I understand how to use to actually mount the partitions.

$ sudo file -s /dev/dm-0 
/dev/dm-0: data
$ sudo file -s /dev/dm-1
/dev/dm-1: data
$ sudo blkid /dev/dm-1
$ sudo blkid /dev/dm-0
$ lsblk -f
NAME   FSTYPE  LABEL UUID                FSAVAIL FSUSE% MOUNTPOINT
...
sdb                                                                        
└─sdb1 LVM2_me       nhgTDJ-m0u9-DQhb-4kQJ-1qmY-X1o3-2GPeEU                
  ├─vg0-database--data
  │                                                                        
  └─vg0-Virtual--Hosts

I have tried mounting the device by using the type listed in file -s output: $ sudo mount -t data /dev/vg0/database-data ~/UBReco/ mount: /home/s/UBReco: unknown filesystem type 'data'.

I have tried mounting the partition using ntfs, various ext fs types, and simply omitting the type argument.

$ sudo mount  -t ntfs /dev/vg0/database-data ~/UBReco/
NTFS signature is missing.
Failed to mount '/dev/mapper/vg0-database--data': Invalid argument
The device '/dev/mapper/vg0-database--data' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?


$ sudo mount -t ext4  /dev/vg0/database-data ~/UBReco/
mount: /home/s/UBReco: wrong fs type, bad option, bad superblock on /dev/mapper/vg0-database--data, missing codepage or helper program, or other error.

$ sudo mount -t ext3  /dev/vg0/database-data ~/UBReco/
mount: /home/s/UBReco: wrong fs type, bad option, bad superblock on /dev/mapper/vg0-database--data, missing codepage or helper program, or other error.

$ sudo mount -t ext2  /dev/vg0/database-data ~/UBReco/
mount: /home/s/UBReco: wrong fs type, bad option, bad superblock on /dev/mapper/vg0-database--data, missing codepage or helper program, or other error.


$ sudo mount   /dev/vg0/database-data ~/UBReco/
mount: /home/s/UBReco: wrong fs type, bad option, bad superblock on /dev/mapper/vg0-database--data, missing codepage or helper program, or other error.

Here is output from sudo fdisk -l

Device     Boot Start       End   Sectors   Size Id Type
/dev/sdb1          63 976768064 976768002 465.8G 83 Linux

Partition 1 does not start on physical sector boundary.


Disk /dev/mapper/vg0-database--data: 100 GiB, 107374182400 bytes, 209715200 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Alignment offset: 512 bytes


Disk /dev/mapper/vg0-Virtual--Hosts: 365 GiB, 391915765760 bytes, 765460480 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Alignment offset: 512 bytes

I dont know what else to do or try. how can I mount this disks partitions and get my data?

1

It does appear the volume group is active. But not showing any signature of a file system as though the logical volumes are not formatted. Perhaps the metadata for the logical volumes has been lost You can gather more data about the volumes with the commands : pvdisplay,pvscan,vgscan,lvs,lvscan.

Try checking the file systems (if ext) with e2fsck.

e2fsck /dev/mapper/{volumegroupname-logicalvolumename}

Maybe an xfs file system, however that should be listed with lsblk -f as you have already done. The volume group has a UUID but there is no UUID or filesystem type listed for the lv's(logical volumes).

If none of that helps and you are absolutely sure there is data there then I would suggest reading up on the testdisk command and see if that will lead you to a solution.

|improve this answer|||||
  • testdisk is solid advice. Why didnt I think of that!? Ill check these other commands out as well. I didnt think it was xfs, but I have done things with xfs in the past. thanks for the post. – j0h Feb 27 at 18:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.