2

So yesterday I received a new laptop with 512 GB of SSD and windows in it, I wanted to start with Linux so I downloaded Kubuntu. I installed in, customized it and the next day it came to my surprise that I could't enter because of beeing stuck in emergency mode. I tried installing it again and it freezed randomly. I tried with KDE Neon and happened the same.

Finally I have unistalled everything and put the partitions together in windows. Does anyone know why this happens and why I can't install Linux in my laptop.

My Laptop is an Acer Swift3 SF314-41 with an AMD Ryzen 5 and a 512 GB SSD

Thank you in advance

  • Have you checked you BIOS settings? Sometimes they cause some issues. Had similar problem in my Dell Precision 5530. – SnowGepard Feb 25 at 12:20
  • I thought that probably could be that, but I'm not really an expert so I don't know what do I have to touch – eneko valero Feb 25 at 14:38
  • 2
    In my case it needed to turn off "secure boot" at change the boot mode to "legacy". But since you could boot from USB the boot mode might not be a problem. Just wonder if the Ryzen 5 Graphic driver might be the issue. – SnowGepard Feb 25 at 14:42
  • 2
    Very likely that without exact error messages, and the computer now restored to Windows-only so you can't post logs and results of commands, we won't be able to answer. – Zeiss Ikon Feb 25 at 14:56
  • Never hurts to disable secure boot, I've had it make things more difficult. As @ZeissIkon mentioned though, we need more details before being able to really help. – Odinson Feb 25 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.