When launching evince, I get this error:

EvinceDocument-WARNING **: 10:14:16.337: Error opening directory “/usr/lib/x86_64-linux-gnu/evince/4/backends”: Permission denied

I have already put evince in complain mode, so I think:

aa-complain /usr/bin/evince

systemctl restart apparmor

Status shows evince is in complain mode:


22 profiles are in complain mode.

I am running Ubuntu with overlayfs root. I have also tried stopping apparmor altogether.

I can do ls -al /usr/lib/x86_64-linux-gnu/evince/4/backends and see the files just fine. If I run strace evince, I see the exact same output, that is cannot open that directory.

  1. How can I fix that?
  2. If it is a fatal error, why is evince logging it as a warning?
  3. If apparmor is permitting access (as evidence in dmesg output (ALLOW)), why is it still complaining?

EDIT: #1

1. Ubuntu 19.10 Server as a base (not as a install, nor a debootstrap, but close to a debootstrap)
2. xorg + i3 tiling wm installed
3. no virtualization
4. most other applications work as expected
  • 1
    To start with, which version of Linux have you installed (Ubuntu server, Ubuntu desktop, Kubuntu, Lubuntu, Xubuntu, Ubuntu MATE, et al.) , and which release number? Are you using virtualization, and if so, which package? Please click edit and add that vital information to your question so all the facts we need are in the question. Please do not use Add Comment.
    – K7AAY
    Feb 24, 2020 at 16:21

2 Answers 2


I solved this by:

  1. temporarily disabling the evince apparmor profile: apparmor_parser -R /etc/apparmor.d/usr.bin.evince
  2. permanently disabling the evince apparmor profile by symlinking /etc/apparmor.d/usr.bin.evince via /etc/apparmor.d/disable
  • I get /etc/apparmor.d/usr.bin.evince: command not found (Ubuntu 20.04)
    – Kvothe
    Mar 21, 2022 at 11:36
  • Thanks. Worked on Ubuntu 22.10.
    – Lynx
    Nov 18, 2022 at 5:24

I would recommend to reinstall the Evince packages first with

sudo apt-get install --reinstall libevdocument3-4 evince-hwp evince

and then retry.

  • I just tried that, no luck.
    – Walter
    Feb 24, 2020 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.