3

I'm a newbie using Ubuntu. I thought I would be able to jump right in and do some C programming with GCC. I can't. So, I searched Google for a beginners guide to get me pointed in the right direction. I found geany. I downloaded and installed geany from the Ubuntu Software Center. It shows up in my apps. When I click on it I get: "geany cannot start! Failed to open file '/share/geany/geany.glade': No such file or directory"

I did an AskUbuntu search and found a page with a lot of discussion and no answer. I ended up following a link to: deb file working fine in version 16.04 does not in 18.04 because someone said installing deb might solve the problem. I installed deb in spite of their talking about problems with it. It seemed to install OK. Being a newbie, I can't be too sure because I don't know enough yet. But it didn't help.

The two pages are over 18 months old. I should think someone would have solved the problem by now. Plus I was given the impression software download from the Ubuntu Software Center was tested and working? Being a new user, I have ignored this problem with other software that I have downloaded from there, uninstalled it and moved on.

But, I would really like to find some help with getting started on C programming with GCC. I have programmed C for 30 years. Borland Turbo C and Pelles C. But, what I thought were common library functions don't work in GCC like the simple gets() function. That's why I looked for beginners help and found geany. I thought I was getting what I needed beings it was in the Ubuntu Software Center.

But it, like many other packages in there, don't work for me. Probably my fault. Even at that, this is really frustrating for a newbie. From the posts I have read, the knowledgeable people on the AskUbuntu site think everyone should know all they know and yet, along with all their snide comments, they fail to answer a question that's been lingering for 18 months? I guess they're from the "If you don't know the answer. Show people your smarter than the dumb person that asked the question school."

Well, I don't pretend to be smart and I still don't know how to get pointed in the right direction in programming C using GCC. Back to Google for help I guess.

By the by, I really like the Ubuntu OS. Thank you people for that. I currently have a dual installation with Windows 10. But, as soon as I can get the things I need to work in Ubuntu, I'll drop Windows and do a full install of Ubuntu. I already have all the prep work done on the dumping Windows side of it. Thanks for any help you can pass along on getting geany to work, Rob

3
  • You could try it.uc3m.es/pbasanta/asng/course_notes/ctut.pdf www3.ntu.edu.sg/home/ehchua/programming/cpp/gcc_make.html or many more found with a startpage.com or equiv. search FYI: Problems need to be reported; the issues mentioned in the link you provided (18+ months ago) are on a user support site (this one) where users talk about problems, to get a developers attention they need to be raised on a bug tracking site (this isn't one). Your 2nd & 3rd paragraphs are somewhat off-topic (meta may be appropriate) & somewhat rant (askubuntu.com/help/dont-ask)
    – guiverc
    Feb 23, 2020 at 10:30
  • Instead of clicking, have you tried typing geany from an xterm? If that works, just correct the link.
    – cup
    Feb 23, 2020 at 10:44
  • I have /usr/share/geany/geany.glade with Geany 1.3.2 from the software center.
    – DK Bose
    Feb 23, 2020 at 10:45

1 Answer 1

9

It looks like there are two versions of geany offered in the Ubuntu Software app.

It's not obvious from the software descriptions, but one of these is a snap package. There appear to be some known issues with that version - for example, one of the user reviews notes exactly the problem you are experiencing:

As noted by others, this version does not load instead you get the error "Geany cannot load Failed to open file '/share/geany/geany.glade':"

Thanks for the offer in the snap store, but look elsewhere if you want it to work

I suggest you remove that version and install the traditional Ubuntu package instead. To distinguish between the versions, scroll down to the Details section and make sure you see

Source: ubuntu-bionic-universe

not

Source: Snap Store

If you prefer to use the command line, you can (as suggested by @norbert) try

snap remove geany-gtk
sudo apt install geany geany-plugins
4
  • 3
    Adding something like snap remove geany-gtk and sudo apt install geany geany-plugins to your answer will be very useful.
    – N0rbert
    Feb 23, 2020 at 13:21
  • Thanks @N0rbert - tbh I wasn't sure of the CLI syntax for snap removal Feb 23, 2020 at 13:41
  • Thank you very much. Removing; then Selecting Source: ubuntu-bionic-universe solved the problem. Plus you taught me to pay more attention to what you're picking to Install. Now more learning can begin...
    – Rob
    Feb 23, 2020 at 21:38
  • Thanks @N0rbert - I followed your suggestion to remove and run: sudo apt install geany geany-plugins . It installed without incident or errors.
    – Rob
    Feb 23, 2020 at 22:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .