0

How can we uninstall LibreOffice when installed from .debs via their website? These make no entries in the Software Center, so cannot be uninstalled that way. And following other guides such as How to uninstall LibreOffice? or Deleting duplicate LibreOffice programs do not work on Lubuntu/APT 1.6.12 - no packages are displayed.

  • A clean install of Lubuntu 18.04 LTS does not have LibreOffice or OpenOffice. The programs supplied are gnumeric (spreadsheet) and abiword (word processor), so how they are removed will depend on how you installed them. I've given some details in my answer, but I have no idea how you installed OpenOffice/Libreoffice (snap, flatpak, appimage, or deb) so I can't tell you how to remove when details of how installed isn't provided. – guiverc Feb 22 at 21:58
2

I would avoid any wildcards in apt commands unless absolutely necessary. In your case I'd opt for listing what is installed (dpkg -l) and just remove those specific packages thus avoiding all complications from the use of wildcards. FYI: Lubuntu is no different to any other Ubuntu (or flavor) for the 18.04 in this regard.

Package managers are an easier bet though; as they list all packages and not just 'selected' ones like Software Centre. synaptic is installed by a default Lubuntu 18.04 LTS installation (https://packages.ubuntu.com/bionic/lubuntu-desktop) and is another option, though there there are many others too. enter image description here

Also please note I booted a very recent QA-test install of Lubuntu 18.04.4 (for the picture), and no LibreOffice packages are installed by default (see prior list of packages installed) so none were found. Your packages may have been installed manually, thus removing them will depend on how you installed them, thus prior details could differ if you installed flatpak, snap etc.

Lubuntu 18.04 LTS comes with abiword and gnumeric only by default, not LibreOffice.

| improve this answer | |
0

The trick is to use double-quotes in an APT search for Lubuntu:

mark@Lubuntu:~$ apt list "libreoffice6.*" "libobasis6.*"
Listing... Done
libobasis6.1-core/now 6.1.3.2-2 amd64 [residual-config]
libobasis6.3-base/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-calc/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-core/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-draw/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-en-us/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-extension-beanshell-script-provider/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-extension-javascript-script-provider/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-extension-mediawiki-publisher/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-extension-nlpsolver/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-extension-pdf-import/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-extension-report-builder/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-firebird/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-gnome-integration/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-graphicfilter/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-images/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-impress/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-kde-integration/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-librelogo/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-libreofficekit-data/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-math/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-ogltrans/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-onlineupdate/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-ooofonts/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-ooolinguistic/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-postgresql-sdbc/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-python-script-provider/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-pyuno/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-writer/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.3-xsltfilter/now 6.3.4.2-2 amd64 [installed,local]
libobasis6.4-base/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-calc/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-core/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-draw/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-en-us/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-extension-beanshell-script-provider/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-extension-javascript-script-provider/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-extension-mediawiki-publisher/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-extension-nlpsolver/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-extension-pdf-import/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-extension-report-builder/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-firebird/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-gnome-integration/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-graphicfilter/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-images/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-impress/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-kde-integration/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-librelogo/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-libreofficekit-data/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-math/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-ogltrans/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-onlineupdate/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-ooofonts/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-ooolinguistic/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-postgresql-sdbc/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-python-script-provider/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-pyuno/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-writer/now 6.4.0.3-3 amd64 [installed,local]
libobasis6.4-xsltfilter/now 6.4.0.3-3 amd64 [installed,local]
libreoffice6.1-debian-menus/now 6.1.3-2 all [residual-config]
libreoffice6.3/now 6.3.4.2-2 amd64 [installed,local]
libreoffice6.3-base/now 6.3.4.2-2 amd64 [installed,local]
libreoffice6.3-calc/now 6.3.4.2-2 amd64 [installed,local]
libreoffice6.3-debian-menus/now 6.3.4-2 all [installed,local]
libreoffice6.3-dict-en/now 6.3.4.2-2 amd64 [installed,local]
libreoffice6.3-dict-es/now 6.3.4.2-2 amd64 [installed,local]
libreoffice6.3-dict-fr/now 6.3.4.2-2 amd64 [installed,local]
libreoffice6.3-draw/now 6.3.4.2-2 amd64 [installed,local]
libreoffice6.3-en-us/now 6.3.4.2-2 amd64 [installed,local]
libreoffice6.3-impress/now 6.3.4.2-2 amd64 [installed,local]
libreoffice6.3-math/now 6.3.4.2-2 amd64 [installed,local]
libreoffice6.3-ure/now 6.3.4.2-2 amd64 [installed,local]
libreoffice6.3-writer/now 6.3.4.2-2 amd64 [installed,local]
libreoffice6.4/now 6.4.0.3-3 amd64 [installed,local]
libreoffice6.4-base/now 6.4.0.3-3 amd64 [installed,local]
libreoffice6.4-calc/now 6.4.0.3-3 amd64 [installed,local]
libreoffice6.4-debian-menus/now 6.4.0-3 all [installed,local]
libreoffice6.4-dict-en/now 6.4.0.3-3 amd64 [installed,local]
libreoffice6.4-dict-es/now 6.4.0.3-3 amd64 [installed,local]
libreoffice6.4-dict-fr/now 6.4.0.3-3 amd64 [installed,local]
libreoffice6.4-draw/now 6.4.0.3-3 amd64 [installed,local]
libreoffice6.4-en-us/now 6.4.0.3-3 amd64 [installed,local]
libreoffice6.4-impress/now 6.4.0.3-3 amd64 [installed,local]
libreoffice6.4-math/now 6.4.0.3-3 amd64 [installed,local]
libreoffice6.4-ure/now 6.4.0.3-3 amd64 [installed,local]
libreoffice6.4-writer/now 6.4.0.3-3 amd64 [installed,local]
mark@Lubuntu:~$

Now it is possible to list only those which you want to remove with apt list "libreoffice6.1*" "libobasis6.1*":

Listing... Done
libobasis6.1-core/now 6.1.3.2-2 amd64 [residual-config]
libreoffice6.1-debian-menus/now 6.1.3-2 all [residual-config]

Now these can be removed with sudo apt purge "libreoffice6.1*" "libobasis6.1*". Check any other versions with list before purging them with purge to ensure it doesn't remove anything else accidentally.

Note at least on my removal of 6.3, it left two dead .desktop files for LibreOffice 6.3 Draw and Math. Solution was to delete them with MenuLibre.

Presto! Left with only v6.4 installed, and over 650MB of disk space freed.

| improve this answer | |
  • 1
    I concede that this could be dangerous, hence why a list should be done first to make sure it will work correctly. Synaptic seems easier though; to do again I'd probably go that route. – rdtsc Feb 23 at 1:02
  • 1
    I like this answer. I merely think it lacks the appropriate warning for future readers, YOU did indeed use it safely. – user535733 Feb 23 at 1:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.