I'm having a lot of difficulty connecting from an ubuntu 18.04 laptop to a hotspot setup on my ubuntu 18.04 desktop.

Laptop card

02:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)

Desktop card

01:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter (rev 03)

I tried the default settings:

  • go into wifi settings
  • choose turn on wifi hotspot
  • select the wifi network on laptop
  • enter password shown as "password" on desktop

I wait a few seconds and I see full bars so I guess it's physically connected in some way, then I get a pop up "Activation of network connection failed".

I've tried

  • changing Ad-Hoc to Hotspot
  • turning off the password
  • changing the password to passphrase (not Hex or Ascii)
  • manually entering the IPv4 connection info for the connection on the laptop as in this post ... I skipped the other answer cos I don't think I want P2P

The laptop can connect fine to my house wifi.

  • So you have Desktop and Laptop.. You have setup wifi hot spot on Desktop. How is the internet connection coming to this Desktop? via LAN or WIFI?? If the internet intake is through the wifi card.. it can not output..
    – PRATAP
    Feb 22, 2020 at 12:42
  • @PRATAP internet's coming to desktop via ethernet
    – joel
    Feb 22, 2020 at 12:44
  • Ok thats fine.. Can you try the below commands once..
    – PRATAP
    Feb 22, 2020 at 12:47
  • nmcli device wifi hotspot ssid TESTING password 12345678 from the Desktop
    – PRATAP
    Feb 22, 2020 at 12:48
  • Error: Invalid 'password': '12345678' is not valid WEP key (it should be 5 or 13 ASCII chars).
    – joel
    Feb 22, 2020 at 12:49


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.