I can’t open a normal text-file (.txt) by clicking on the file.

The only way I can open the file is to right-click and select "open with another application" and then click the select button.

Or open the text editor (gedit in my chase), and open the file from there.

My Default text editor is gedit, but I have try with mousepad to. with the same results

I running Ubuntu server 18.04 with a xubuntu core gui on

As an attempt I took and installed Thunar, and from Thunar it works to open text file with double click. But not from Nautilus, can I miss any package?

  • 1
    Does anything happen if you double click on the file? Feb 21, 2020 at 21:44
  • 2
    if you do: $gedit filename what happens? does the terminal give you any info?
    – j0h
    Feb 21, 2020 at 21:48
  • 2
    Don't you have the <right click> Properties -> Open with option? Feb 21, 2020 at 21:52
  • the only thing that happens when I double-click the file is that the machine "thinks" .... Opening the file through the terminal worked well
    – Skalman65
    Feb 22, 2020 at 5:17

1 Answer 1


What is your File Manager?

For me this worked:

  1. In a file browser window, Help > About revealed my file manager is Nemo.
  2. Again in the a Nemo file browser window, Edit > Preferences > Behavior > Executable Text Files
  3. Changed from "Execute text file" to "View text file."

After this I could double click a .txt file to view it, whereas before nothing happened. The default Open With had already been gedit.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .