1

I'm relatively new to Ubuntu, so this is the first time I've seen something like this.

After successfully installing Ubuntu in a laptop I wasn't using (Lenovo Ideapad 120s), I'm stuck in an infinite loop.

  • First the logo appears.
  • Then, the screen flashes with the message: 'System BootOrder not found. Initializing defaults. Reset System'
  • It keeps running infinitely, first the logo and then the message again.

I've tried restarting the laptop, entering the BIOS and changing its settings, but I'm not sure if there's something I can do there to stop the loop from happening.

If it's of any help, this problem started when I turned off the laptop after updating Ubuntu. When I turned it on again and tried to use Windows 10 (dual boot) to check if there were any problems, the infinite loop began.

Any help is welcome.

EDIT: Ubuntu 18.04.4-desktop version

1
  • 1
    To start with, which version of Linux have you installed (Ubuntu server, Ubuntu desktop, Kubuntu, Lubuntu, Xubuntu, Ubuntu MATE, et al.) , and which release number? Please click edit and add that vital information to your question so all the facts we need are in the question. Please do not use Add Comment.
    – K7AAY
    Feb 21, 2020 at 18:42

1 Answer 1

1

You can use Boot Repair. It will regenerate your GRUB and boot installation. To install it:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt install --assume-yes boot-repair
boot-repair

If you cannot access to Ubuntu anymore, use a live CD/USB: https://ubuntu.com/tutorials/try-ubuntu-before-you-install#1-getting-started and select the "Try Ubuntu" option. Then install there Boot Repair and follow instructions.

Also, as you have an "old" laptop, you should use Xubuntu or Lubuntu, which are lightweight distributions, maybe more suitable for your laptop's configuration.

3
  • Thank you!! It worked perfectly! :)
    – Jorge
    Feb 21, 2020 at 23:21
  • My pleasure! ;)
    – Likid
    Feb 21, 2020 at 23:43
  • @Likid +1 for a good solution! I was going in a different direction with efibootmgr.
    – heynnema
    Feb 22, 2020 at 0:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.