2

We stopped using a proxy for internet access for our Ubuntu 18 servers and everything is working fine, except that the unattended security upgrades are failing with still trying to use the proxy settings and I can't workout where it's picking them up from..

Previously the proxy setting had been set in /etc/environment, but these have been removed, I've set Acquire::http::Proxy "false"; in /etc/apt/apt.conf which was required to fix the manual running of apt get update command (this works fine now).

However the /var/log/unattended-upgrades/unattended-upgrades.log are showing:

2020-02-21 05:35:41,234 INFO Starting unattended upgrades script
2020-02-21 05:35:41,234 INFO Allowed origins are: o=Ubuntu,a=bionic, o=Ubuntu,a=bionic-security, o=UbuntuESM,a=bionic
2020-02-21 07:00:16,993 INFO Initial blacklisted packages:
2020-02-21 07:00:16,994 INFO Initial whitelisted packages:
2020-02-21 07:00:16,995 INFO Starting unattended upgrades script
2020-02-21 07:00:16,995 INFO Allowed origins are: o=Ubuntu,a=bionic, o=Ubuntu,a=bionic-security, o=UbuntuESM,a=bionic
2020-02-21 07:00:51,210 ERROR An error occurred: Invalid response from proxy: HTTP/1.1 403 Forbidden  Mime-Version: 1.0  Date: Fri, 21 Feb 2020 10:50:31 GMT  Via: 1.1 old_proxy.domain.xxx.uk:80 (Cisco-WSA/8.5.3-064)  Content-Type: text/html  Connection: keep-alive  Proxy-Connection: keep-alive  Content-Length: 2416     [IP: xx.xx.xx.xx 80]
2020-02-21 07:00:51,211 ERROR The URI http://archive.ubuntu.com/ubuntu/pool/main/e/e2fsprogs/libext2fs2_1.44.1-1ubuntu1.3_amd64.deb failed to download, aborting

We have a few Ubuntu servers that were rebuilt more recently that never had any proxy settings configurated at any time and these are working okay too, so that's why I assume there's a residual caching of the proxy settings somewhere, but I don't know where that would be. Or where do I need to explicitly tell Ubuntu to not use a proxy in order to get this working again?

Many thanks

  • One assumes you have already been through the many config files in /etc/apt/apt.conf.d/*? – user535733 Feb 21 at 12:30
  • Ah, yes, thank you - I hadn't (but should have done!) It looks like it had been written to /etc/apt/apt.conf.d/90curtin-aptproxy, so needs removing from there too. I'm assuming this will fix it. Thank you! – 16shells Feb 21 at 12:41
2

Thanks to user535733 for the solution, I hadn't thought to check all the files:

The system had copied the proxy settings to /etc/apt/apt.conf.d/90curtin-aptproxy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.