2

My laptop (Dell Inspiron 5590 with Ubuntu 19.10 and kernel 5.3.0-40) was working fine until yesterday. When I turned it on I could not connect to the internet. I noticed that "Aeroplane mode" was switched on, but when I switched it off it said "No Wi-Fi Adapter Found" in settings. I also noticed that if I left the computer inactive for a short time it would freeze.

This is similar to: 19.10: Thinkpad L13: Intel 9560: wifi interface suddenly disappeared and Intel Wifi Card Stopped Working After Software Update

A comment to the above post suggested booting with a previous kernel (5.3.0-29). When I do this I can detect the Wi-Fi adapter and connect to the internet with no problems. However the system still freezes after a short amount of inactivity. Please can anyone advise me on this problem. Thanks!

Note: I do not have a Wi-Fi switch button to toggle. And I checked that Wi-Fi is enabled on the BIOS.

Output about Wi-Fi adapter, firmware and kernel:

>>lspci -nn | grep -i network
00:14.3 Network controller [0280]: Intel Corporation Device [8086:02f0]

>>uname -r
5.3.0-40-generic

>>iwconfig
lo        no wireless extensions.

>>sudo lshw -C network
  *-network                 
       description: Network controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 14.3
       bus info: pci@0000:00:14.3
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list
       configuration: driver=iwlwifi latency=0
       resources: irq:16 memory:c2218000-c221bfff

>> sudo dpkg -s linux-firmware | grep Ver
Version: 1.183.4

>> modinfo iwlwifi | egrep 'filename|intree'
filename:       /lib/modules/5.3.0-40-generic/kernel/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko
intree:         Y

>> rfkill list
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

Here are two outputs from dmesg:

>> dmesg | grep -i firm
[    0.152619] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    2.420343] iwlwifi 0000:00:14.3: loaded firmware version 48.4fa0041f.0 op_mode iwlmvm
[    2.462387] Bluetooth: hci0: Firmware revision 0.0 build 62 week 31 2019
[    2.686507] [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
[    2.862605] [Firmware Bug]: ACPI(PXSX) defines _DOD but not _DOS
[    3.497542] iwlwifi 0000:00:14.3: Loaded firmware version: 48.4fa0041f.0
[    3.497731] iwlwifi 0000:00:14.3: Firmware not running - cannot dump error

>>dmesg | grep iwl
[    2.366865] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[    2.420150] iwlwifi 0000:00:14.3: TLV_FW_FSEQ_VERSION: FSEQ Version: 43.2.23.17
[    2.420343] iwlwifi 0000:00:14.3: loaded firmware version 48.4fa0041f.0 op_mode iwlmvm
[    2.468834] iwlwifi 0000:00:14.3: Detected Intel(R) Wireless-AC 9462, REV=0x354
[    3.497417] iwlwifi 0000:00:14.3: Collecting data: trigger 15 fired.
[    3.497541] iwlwifi 0000:00:14.3: Start IWL Error Log Dump:
[    3.497541] iwlwifi 0000:00:14.3: Status: 0x00000000, count: -144310389
[    3.497542] iwlwifi 0000:00:14.3: Loaded firmware version: 48.4fa0041f.0
[    3.497543] iwlwifi 0000:00:14.3: 0xEEB1EBD3 | ADVANCED_SYSASSERT          
[    3.497544] iwlwifi 0000:00:14.3: 0x58011C15 | trm_hw_status0
[    3.497544] iwlwifi 0000:00:14.3: 0x60C5819E | trm_hw_status1
[    3.497545] iwlwifi 0000:00:14.3: 0x7EBF2DF8 | branchlink2
[    3.497545] iwlwifi 0000:00:14.3: 0xAE9FEC6A | interruptlink1
[    3.497546] iwlwifi 0000:00:14.3: 0xD6C20A3C | interruptlink2
[    3.497546] iwlwifi 0000:00:14.3: 0x81524AD0 | data1
[    3.497547] iwlwifi 0000:00:14.3: 0xC7FD9BBF | data2
[    3.497547] iwlwifi 0000:00:14.3: 0x6BFEF09C | data3
[    3.497548] iwlwifi 0000:00:14.3: 0x81448886 | beacon time
[    3.497548] iwlwifi 0000:00:14.3: 0x29C07820 | tsf low
[    3.497549] iwlwifi 0000:00:14.3: 0xFEF57BD7 | tsf hi
[    3.497549] iwlwifi 0000:00:14.3: 0x97EB7B0D | time gp1
[    3.497550] iwlwifi 0000:00:14.3: 0x8887938B | time gp2
[    3.497550] iwlwifi 0000:00:14.3: 0xC6A8C241 | uCode revision type
[    3.497551] iwlwifi 0000:00:14.3: 0xD8EBBC3F | uCode version major
[    3.497551] iwlwifi 0000:00:14.3: 0xBBA5EB7F | uCode version minor
[    3.497552] iwlwifi 0000:00:14.3: 0x4A922D18 | hw version
[    3.497552] iwlwifi 0000:00:14.3: 0x8416AC04 | board version
[    3.497553] iwlwifi 0000:00:14.3: 0xD2084183 | hcmd
[    3.497553] iwlwifi 0000:00:14.3: 0x5B77FBFF | isr0
[    3.497553] iwlwifi 0000:00:14.3: 0xEBB7B4E3 | isr1
[    3.497554] iwlwifi 0000:00:14.3: 0xB2478CDC | isr2
[    3.497554] iwlwifi 0000:00:14.3: 0x2590D985 | isr3
[    3.497555] iwlwifi 0000:00:14.3: 0xFDFB7EE5 | isr4
[    3.497555] iwlwifi 0000:00:14.3: 0x755BCBC3 | last cmd Id
[    3.497556] iwlwifi 0000:00:14.3: 0x55C00030 | wait_event
[    3.497556] iwlwifi 0000:00:14.3: 0x72033383 | l2p_control
[    3.497557] iwlwifi 0000:00:14.3: 0xF3D7D9CE | l2p_duration
[    3.497557] iwlwifi 0000:00:14.3: 0xDA9CC4BE | l2p_mhvalid
[    3.497558] iwlwifi 0000:00:14.3: 0x44418141 | l2p_addr_match
[    3.497558] iwlwifi 0000:00:14.3: 0x75022011 | lmpm_pmg_sel
[    3.497559] iwlwifi 0000:00:14.3: 0x7A776FEB | timestamp
[    3.497559] iwlwifi 0000:00:14.3: 0xF6BEF69E | flow_handler
[    3.497609] iwlwifi 0000:00:14.3: Start IWL Error Log Dump:
[    3.497609] iwlwifi 0000:00:14.3: Status: 0x00000000, count: 7
[    3.497610] iwlwifi 0000:00:14.3: 0x201013F1 | ADVANCED_SYSASSERT
[    3.497610] iwlwifi 0000:00:14.3: 0x00000000 | umac branchlink1
[    3.497611] iwlwifi 0000:00:14.3: 0xC008CF5C | umac branchlink2
[    3.497611] iwlwifi 0000:00:14.3: 0x00000000 | umac interruptlink1
[    3.497612] iwlwifi 0000:00:14.3: 0x00000000 | umac interruptlink2
[    3.497612] iwlwifi 0000:00:14.3: 0x00000003 | umac data1
[    3.497613] iwlwifi 0000:00:14.3: 0x20000302 | umac data2
[    3.497613] iwlwifi 0000:00:14.3: 0x00000201 | umac data3
[    3.497614] iwlwifi 0000:00:14.3: 0x00000030 | umac major
[    3.497614] iwlwifi 0000:00:14.3: 0x4FA0041F | umac minor
[    3.497615] iwlwifi 0000:00:14.3: 0x00005C89 | frame pointer
[    3.497615] iwlwifi 0000:00:14.3: 0xC0887F58 | stack pointer
[    3.497616] iwlwifi 0000:00:14.3: 0x00000000 | last host cmd
[    3.497616] iwlwifi 0000:00:14.3: 0x00000000 | isr status reg
[    3.497632] iwlwifi 0000:00:14.3: Fseq Registers:
[    3.497635] iwlwifi 0000:00:14.3: 0x00000003 | FSEQ_ERROR_CODE
[    3.497637] iwlwifi 0000:00:14.3: 0x00260000 | FSEQ_TOP_INIT_VERSION
[    3.497639] iwlwifi 0000:00:14.3: 0x80020006 | FSEQ_CNVIO_INIT_VERSION
[    3.497641] iwlwifi 0000:00:14.3: 0x0000A384 | FSEQ_OTP_VERSION
[    3.497643] iwlwifi 0000:00:14.3: 0x42E1014D | FSEQ_TOP_CONTENT_VERSION
[    3.497646] iwlwifi 0000:00:14.3: 0x4552414E | FSEQ_ALIVE_TOKEN
[    3.497648] iwlwifi 0000:00:14.3: 0x20000302 | FSEQ_CNVI_ID
[    3.497650] iwlwifi 0000:00:14.3: 0x00000201 | FSEQ_CNVR_ID
[    3.497653] iwlwifi 0000:00:14.3: 0x20000302 | CNVI_AUX_MISC_CHIP
[    3.497657] iwlwifi 0000:00:14.3: 0x00000201 | CNVR_AUX_MISC_CHIP
[    3.497662] iwlwifi 0000:00:14.3: 0x0000485B | CNVR_SCU_SD_REGS_SD_REG_DIG_DCDC_VTRIM
[    3.497696] iwlwifi 0000:00:14.3: 0xA5A5A5A2 | CNVR_SCU_SD_REGS_SD_REG_ACTIVE_VDIG_MIRROR
[    3.497729] iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x5bfc, CPU2 Status: 0x3
[    3.497729] iwlwifi 0000:00:14.3: Failed to start RT ucode: -110
[    3.497731] iwlwifi 0000:00:14.3: Firmware not running - cannot dump error
[    3.509548] iwlwifi 0000:00:14.3: Failed to run INIT ucode: -110

Just in case it is relevant here is a link to the log from my update manager /var/log/apt/history.log https://pastebin.com/B2LS6uB2

1
1

Seems that kernel 5.3.0-40 update breaks intel Wifi. I had same problem same week, as well al this question author: 19.10: Thinkpad L13: Intel 9560: wifi interface suddenly disappeared

Reboot, go to GRUB menu and select ...-29 kernel. If it solves the issue, then purge -40 in the shell as it's recommended in that answer.

0

I had the same problem with Intel(R) Wireless-AC 9462. Upgrade the kernel to 5.5.5 solved it.

0
0

As you said, part of an issue have been resolved by different kernel using. The remaining part of an issue could be resolved by switching to other kernel too. You could also use another generic, liquorix, xanmod, lowlatency kernels.

Also, maybe some faulty drivers have been received during the last upgrade. After trying different kernels, examine what drivers have been upgraded.

You could use the next command to see what packages have been upgraded starting from date you've noticed an issue:

cat /var/log/dpkg.log | grep "^2020-02-21.*\ installed\ "

Look if there are driver-related packages you could try to downgrade to old, previously working versions one by one, checking which driver downgrade resolved the issue.

Also, you could see packages downloading history by listing cached packages sorting them by date (tr in the next command - sorting by date):

ls -ailhtr /var/cache/apt/archives/
0

I dealt with the same problem. Try this:

  1. disable Secure Boot in UEFI (BIOS) settings

  2. reinstall linux firmware sudo apt install linux-firmware

  3. add in grub the parameter pcie_aspm=off :

    sudo gedit /etc/default/grub

    Add pcie_aspm=off to the GRUB_CMDLINE_LINUX_DEFAULT

  4. reboot

It worked for me, Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.