3

I have a USB camera: Novatel Wireless Merlin U740 (https://linux-hardware.org/index.php?id=usb:1410-1410) and unfortunately it doesn't seem to work (Ubuntu 18.04, everything up to date).

Here is what I get from lsusb:

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 007: ID 1410:1410 Novatel Wireless Merlin U740 (non-Vodafone)
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 1ea7:0064  
Bus 001 Device 002: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

dmesg after plugging it in:

[  667.771452] usb 3-2: new high-speed USB device number 7 using xhci_hcd
[  668.012445] usb 3-2: New USB device found, idVendor=1410, idProduct=1410, bcdDevice= 0.00
[  668.012447] usb 3-2: New USB device strings: Mfr=2, Product=1, SerialNumber=0
[  668.012449] usb 3-2: Product: USB 2.0 Camera
[  668.012450] usb 3-2: Manufacturer: Sonix Technology Co., Ltd.
[  668.021479] option 3-2:1.0: GSM modem (1-port) converter detected
[  668.023851] option 3-2:1.1: GSM modem (1-port) converter detected
[  668.025476] option 3-2:1.2: GSM modem (1-port) converter detected
[  668.025536] option 3-2:1.3: GSM modem (1-port) converter detected

lsmod | grep video

uvcvideo               94208  0
videobuf2_vmalloc      20480  1 uvcvideo
videobuf2_memops       20480  1 videobuf2_vmalloc
videobuf2_v4l2         24576  1 uvcvideo
videobuf2_common       49152  2 videobuf2_v4l2,uvcvideo
videodev              208896  3 videobuf2_v4l2,uvcvideo,videobuf2_common
mc                     53248  5 videodev,snd_usb_audio,videobuf2_v4l2,uvcvideo,videobuf2_common

ls /dev/video*

ls: cannot access '/dev/video*': No such file or directory

I switched to proprietary Nvidia drivers but that didn't help (rebooted afterwards). Given that I'm out of ideas, did anyone had similar issues with this particular cam or one from that manufacturer?

It's probably worth pointing out that the same cam works on my laptop with the same distro and kernel installed.

2

Ubuntu thinks it is the modem. Try to blacklist option driver. The uvcvideo should be loaded automatically in this case on the next boot.

| improve this answer | |
2

Just a follow up to linuxbuild's answer...

For this particular camera, which I also own, on LinuxMint 18.3, I added the following to /etc/modprobe.d/blacklist-modem.conf, and it worked after reboot:

blacklist usb_wwan
install usb_wwan /bin/false

Likely the last line is the only one needed, but I was working my way down the "how to blacklist drivers" thread, and that is when it worked.

| improve this answer | |
  • For the record this answer worked for me in a Raspberry PI 4 with Raspbian GNU/Linux 10 (buster). Thank you @Sir_Ty – Francesc Guasch May 19 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.