0

I am using Ubuntu 16.04 and I have been using Gimp for long time. Out of a sudden it refused to open complaining about:

libstdc++.so.6: cannot open shared object file: No such file or directory

I tried to install this library using:

$sudo apt-get install libstdc++6

or even (for 32bit although I don't think I am using a 32bit version): $sudo apt-get install lib32stdc++6

to no avail. I tired copying the existing libraries to the Gimp folder but since I have install it via snap it failed stating it's a read only system.

Then, I tried removing Gimp and reinstall it but it also failed (the installation part) stating:

libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

I have managed to install it via $sudo apt install gimp but the installed version is too old to be satisfactory (2.8.16).

So, how can I install (via snap preferably) gimp in my system? And how come it stopped working all of a sudden (not even a reboot took place between the working and not working phase of Gimp by the way).

  • did you try to install it from Snap? snapcraft.io/gimp – JoKeR Feb 21 at 9:03
  • Remove the old package and install from snap if you want snap version – JoKeR Feb 21 at 9:04
  • As I mentioned I removed the old snap version and tried to install it via snap and it failed. Isn't clear from above? – Eypros Feb 21 at 10:22
  • "failed stating it's a read only system" - sometimes real bad. Look up how to run a SMART test on your hard drive. – user535733 Feb 21 at 13:01
  • 1
    Does this answer your question? How do I restore the default repositories? – N0rbert Feb 21 at 16:22
1

Apparently the version which snap tried to update to (or managed to update to) has some bugs which prevents it from being executed.

The revision that failed in my case is 245 (I think the version is 2.10.14). As I mentioned I tried to reinstall it but to no avail, so, I tried the candidate (rev 246) channel which does not seem to suffer from the same bug:

$sudo snap install --channel=candidate gimp

I hope that the developers will fix the bug and I can use the stable channel once again or alternatively that the candidate is stable enough to not cause me a lot of trouble.

P.S.
For some reason I could not manage to install Gimp 2.10 via PPA in Ubuntu 16.04

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.