2

My original intention was to install ubuntu along side of windows 10 (dual boot) on newly purchased Acer Aspire A515-54G but live/install cannot find hard-drive.
After trying all the suggestions i could find i am now stuck: live ubuntu: fdisk -l only displays sda -> which is usb drive...

fdisk -l
Disk /dev/loop0: 1.9 GiB, 2029981696 bytes, 3964808 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

...

Disk /dev/loop7: 956 KiB, 978944 bytes, 1912 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/sda: 14.9 GiB, 16000221184 bytes, 31250432 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 976216C9-3B66-49DA-80EE-10EEF6FE1182

Device     Start      End  Sectors  Size Type
/dev/sda1   2048 31250398 31248351 14.9G Microsoft basic data
lsblk -f
NAME   FSTYPE   LABEL       UUID                                 MOUNTPOINT  
loop0  squashfs                                                  /rofs
loop1  squashfs                                                  /snap/core/8268
loop2  squashfs                                                  /snap/core18/1668
loop3  squashfs                                                  /snap/gtk-common-themes/1440
loop4  squashfs                                                  /snap/gnome-3-28-1804/116
loop5  squashfs                                                  /snap/gnome-calculator/544
loop6  squashfs                                                  /snap/gnome-characters/399
loop7  squashfs                                                  /snap/gnome-logs/81
loop8  squashfs                                                  /snap/gnome-system-monitor/127
sda                                                              
└─sda1 vfat     UBUNTU 18_0 AEC5-1174                            /cdrom

I tried:

 sudo dmraid -E -r /dev/sda 
... but to no avail.

I have tried all sorts of edits to the bios/uefi:
1. Disabled: Secure boot
2. Disabled: Fast boot
3. Enabled: f12 boot mode
4. Updated uefi firmware.
5. Rolled back firmware...
There is no option that i can find to change to SATA AHCI in the bios menu. The laptop uses RST with optane but all options are disabled through the intel app.
The only thing I haven't tried is Selecting an UEFI file as a trusted for executing... because I don't know what this really does...?
Totally lost. please help me escape my windows purgatory...
SOME BIOS SCREEN SHOTS

  • 1
    Welcome to AskUbuntu, I found this article. community.acer.com/en/discussion/584990/a515-54-708w It says the SATA mode is hidden. You can toggle the AHCI mode then. – Sadaharu Wakisaka Feb 21 at 1:07
  • 1
    Awesome! Thanks for the lead. Hitting CTRL + S on Main tab of the BIOS magically makes the hidden SATA mode option appear. I Enabled Safe boot mode, made the change from RST with optane to AHCI. Restarted windows in safe mode with networking, ensured the AHCI drivers were good. Turned off safe mode boot. popped in the live/install usb and everything went smoothly. You saved me from buying another HD. Thanks! – DANE O Feb 21 at 21:18
  • 1
    Good to hear that you made it. It's not a bad idea to have two computers for the different OS. One machine, one OS, how simple is that. – Sadaharu Wakisaka Feb 22 at 0:30
1


sadaharu-wakisaka found a solution:

  1. Enable windows safe mode.
    • run msconfig -
    • ctrl + r -> input : msconfig
    • from boot top tab -> BOOT Options -> safe mode selection button -> network -> apply -> ok -> restart + shift...

      upon restart safe mode will be indicated by 'safe mode' displayed in four corners of screen.
      NOTE: my wifi didn't work in safe mode, and I had to plug in direct ethernet.

    • Don't forget to undo this config when you are done with safe mode.
  2. On Restart hold shift + -> select reboot to enter UEFI/BIOS on reboot.
  3. In the Main Tab of the BIOS, hit CTRL + S to show hidden SATA MODE option, change sata mode to ahci and then save the change.
    Windows will install the ahci driver on safe boot.

    • After ensuring the AHCI driver were up to date;

      device manager -> IDE ATA/ATAPI -> SATA AHCI controller -> Right click on it and select Update Driver Software

    • Removed the safe boot option from step 1.

After changing to AHCI mode everything went very smoothly.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.