0

About two month ago I received at work Lenovo ThinkPad L13 (Core i7 10th gen), and installed Ubuntu 18.04. WiFi wasn't working, but I managed to fix it by installing linux-image-generic-hwe-18.04_5.3.0.40.97_i386.deb as advised here Wifi on Lenovo P1 with Ubuntu 18.04 no longer works by running

sudo apt install --install-suggests linux-image-generic-hwe-18.04

Today my system was updated and required a reboot, after I got this problem again. I tried the same command, but no success (the latest version installed, still no WiFi).

linux-image-generic-hwe-18.04 is already the newest version (5.3.0.40.97).
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.

I also tried this one Ubuntu 18.04 / iwlwifi : recurrent problems, now Airplane Mode activated and impossible to remove after suspend but it didn't help me, as well as this one Wi-Fi not working on Lenovo ThinkPad E570 (Realtek RTL8821CE)

Any ideas how to fix it?

ps lspci giving this output

00:00.0 Host bridge: Intel Corporation Device 9b61 (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Device 9b41 (rev 02)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 0c)
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Device 02f9
00:13.0 Serial controller: Intel Corporation Device 02fc
00:14.0 USB controller: Intel Corporation Device 02ed
00:14.2 RAM memory: Intel Corporation Device 02ef
00:14.3 Network controller: Intel Corporation Device 02f0
00:15.0 Serial bus controller [0c80]: Intel Corporation Device 02e8
00:16.0 Communication controller: Intel Corporation Device 02e0
00:1d.0 PCI bridge: Intel Corporation Device 02b0 (rev f0)
00:1d.4 PCI bridge: Intel Corporation Device 02b4 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Device 0284
00:1f.3 Audio device: Intel Corporation Device 02c8
00:1f.4 SMBus: Intel Corporation Device 02a3
00:1f.5 Serial bus controller [0c80]: Intel Corporation Device 02a4
00:1f.6 Ethernet controller: Intel Corporation Device 0d4f
03:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM981/PM981
05:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)
  • What's the output of rfkill? – Murphy Feb 20 at 21:44
  • ID TYPE DEVICE SOFT HARD 0 bluetooth hci0 unblocked unblocked – timanix Feb 21 at 11:07
2

Fixed it. As I thought, the issue was in the latest update of the kernel.

  1. Reboot your machine and press shift or escape while it is loading to get to GRUB menu
  2. Choose Advanced options
  3. Load with a previous kernel, not the upper one (not a recovery one as well). Remember the number of upper kernel to delete it later. Laptop should load normally with WiFi working
  4. Remove bad update. In my case it's one I indicated, if yours are different, change it.

    sudo apt-get purge linux-image-5.3.0-40-generic

    sudo apt-get purge linux-headers-5.3.0-40-generic

| improve this answer | |
1

Lenovo thinkpad L13 wifi works fine under kernels: 5.3.0-18 (from ubuntu19.10)

5.5.11, 5.6.2 from https://kernel.ubuntu.com/~kernel-ppa/mainline/

sudo lshw |grep Wireless -A12 -B1

        *-network:0         
             description: Wireless interface
             product: Intel Corporation
             vendor: Intel Corporation
             physical id: 14.3
             bus info: pci@0000:00:14.3
             logical name: wlp0s20f3
             version: 00
             width: 64 bits
             clock: 33MHz
             capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
             configuration: broadcast=yes driver=iwlwifi driverversion=5.6.2-050602-generic firmware=48.4fa0041f.0 QuZ-a0-jf-b0-48.u ip=192.168.88.94 latency=0 link=yes multicast=yes wireless=IEEE 802.11
             resources: irq:16 memory:71338000-7133bfff
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.