0

Firefox is not displaying pages properly after Ubuntu updates on 19 Feb 2020. Firefox itself upgraded to 73.0 on 18 Feb.

Chrome was updated at the same time. It does not exhibit the same problem.

Here's a selection of updates from both both dates:

2020-02-18 07:27:14 upgrade chromium-codecs-ffmpeg-extra:amd64 79.0.3945.130-0ubuntu0.18.04.1 80.0.3987.87-0ubuntu0.18.04.1
2020-02-18 07:27:20 upgrade firefox:amd64 72.0.2+build1-0ubuntu0.18.04.1 73.0+build3-0ubuntu0.18.04.1
2020-02-18 07:27:36 upgrade firefox-locale-en:amd64 72.0.2+build1-0ubuntu0.18.04.1 73.0+build3-0ubuntu0.18.04.1
2020-02-18 09:15:21 upgrade google-chrome-stable:amd64 80.0.3987.87-1 80.0.3987.106-1
2020-02-18 09:15:29 upgrade code:amd64 1.42.0-1580986622 1.42.1-1581432938
2020-02-19 09:38:39 upgrade gir1.2-webkit2-4.0:amd64 2.26.3-0ubuntu0.18.04.1 2.26.4-0ubuntu0.18.04.1
2020-02-19 09:38:40 upgrade gir1.2-javascriptcoregtk-4.0:amd64 2.26.3-0ubuntu0.18.04.1 2.26.4-0ubuntu0.18.04.1
2020-02-19 09:38:46 upgrade libwebkit2gtk-4.0-37:amd64 2.26.3-0ubuntu0.18.04.1 2.26.4-0ubuntu0.18.04.1
2020-02-19 09:38:47 upgrade libjavascriptcoregtk-4.0-18:amd64 2.26.3-0ubuntu0.18.04.1 2.26.4-0ubuntu0.18.04.1
2020-02-19 09:39:24 upgrade php7.2-cli:amd64 7.2.24-0ubuntu0.18.04.2 7.2.24-0ubuntu0.18.04.3
2020-02-19 09:39:24 upgrade php7.2-common:amd64 7.2.24-0ubuntu0.18.04.2 7.2.24-0ubuntu0.18.04.3
2020-02-19 09:39:50 upgrade linux-generic:amd64 4.15.0.76.78 4.15.0.88.80
2020-02-19 11:36:37 upgrade libnss-systemd:amd64 237-3ubuntu10.38 237-3ubuntu10.39
2020-02-19 11:36:37 upgrade udev:amd64 237-3ubuntu10.38 237-3ubuntu10.39
2020-02-19 11:36:38 upgrade libpam-systemd:amd64 237-3ubuntu10.38 237-3ubuntu10.39
2020-02-19 11:36:38 upgrade systemd:amd64 237-3ubuntu10.38 237-3ubuntu10.39
2020-02-19 11:36:41 upgrade google-chrome-stable:amd64 80.0.3987.106-1 80.0.3987.116-1
2020-02-19 11:36:51 upgrade libfwupd2:amd64 1.0.9-0ubuntu2 1.2.10-1ubuntu2~ubuntu18.04.3
2020-02-19 11:36:51 upgrade fwupd:amd64 1.0.9-0ubuntu2 1.2.10-1ubuntu2~ubuntu18.04.3

Screenshot:

eg. askubuntu

2
  • 1
    Do you mean javascript? What do you see with all extensions disabled? – DK Bose Feb 20 '20 at 12:53
  • Alas, no. It's still completely knackered-up when you disable all add-ons and open in safe mode. – markling Feb 20 '20 at 13:57
0

The problem was caused by my desktop running a high-contrast theme. It is necessary to tell Firefox to ignore this, ironically, in order to see elements on the page.

Do this by going to Firefox options menu and look for: preferences > general > fonts and colours : colours : Override the colours specified by the page with your selections above ... and select Never.

Solution was found here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.