0

I am using Kubuntu 18.04

My computer boots to the grub menu, but all that shows up is Ubuntu, Advanced Options for Ubuntu, and some weird EFI stuff (they all say invalid root).

Here is what I have done

  • os-prober -> update-grub : Doesn't detect Windows, and I have ntfs-3g
  • Made a custom entry for grub described here, says 'invalid file'
  • Did a boot repair, nothing changes
  • Mounted windows, I am able to see my windows files from Ubuntu.
  • Tried grub-install /dev/sda2, and this was produced...
sudo grub-install /dev/sda2
Installing for x86_64-efi platform.
GUID Partition Table Header signature is wrong: be5608740128e852 != 5452415020494645
GUID Partition Table Header signature is wrong: 0 != 5452415020494645
GUID Partition Table Header signature is wrong: be5608740128e852 != 5452415020494645
GUID Partition Table Header signature is wrong: 0 != 5452415020494645
GUID Partition Table Header signature is wrong: be5608740128e852 != 5452415020494645
GUID Partition Table Header signature is wrong: 0 != 5452415020494645
Installation finished. No error reported.

My lsblk looks like this: The 600G space is windows

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 931.5G  0 disk 
├─sda1   8:1    0     1G  0 part 
├─sda2   8:2    0   600G  0 part 
├─sda3   8:3    0  17.2G  0 part 
├─sda4   8:4    0     1K  0 part 
├─sda5   8:5    0    14G  0 part /
├─sda6   8:6    0   2.8G  0 part [SWAP]
├─sda7   8:7    0   237M  0 part /boot/efi
└─sda8   8:8    0 294.3G  0 part /home

My fdisk -l looks like this:

Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xc0ff3237

Device     Boot      Start        End    Sectors   Size Id Type
/dev/sda1             2048    2101247    2099200     1G  7 HPFS/NTFS/exFAT
/dev/sda2  *       2101248 1260392447 1258291200   600G  7 HPFS/NTFS/exFAT
/dev/sda3       1913182208 1949319167   36136960  17.2G  7 HPFS/NTFS/exFAT
/dev/sda4       1260394494 1913180159  652785666 311.3G  5 Extended
/dev/sda5       1260394496 1289689087   29294592    14G 83 Linux
/dev/sda6       1289691136 1295548415    5857280   2.8G 82 Linux swap / Solaris
/dev/sda7       1295550464 1296035839     485376   237M ef EFI (FAT-12/16/32)
/dev/sda8       1296037888 1913180159  617142272 294.3G 83 Linux

Partition 4 does not start on physical sector boundary.
Partition table entries are not in disk order.
  • To start with, which version of Linux have you installed (Ubuntu server, Ubuntu desktop, Kubuntu, Lubuntu, Xubuntu, Ubuntu MATE, et al.) , and which release number? Please click edit and add that vital information to your question so all the facts we need are in the question. Please do not use Add Comment. – K7AAY Feb 19 at 17:27
  • 1
    Are both systems UEFI or both BIOS boot? And is Windows fast start up off? UEFI & BIOS are not compatible, once you start booting in one mode or other you cannot change. Or from grub you can only boot other installs in same boot mode. And if fast start up not off in Windows, it is hibernated and then grub cannot see your Windows install. – oldfred Feb 19 at 18:36
  • How would I go about checking this? I think the linux is UEFI, because there is a /boot/efi partition. Fast boot is turned off for Windows. – TheRealConner Feb 19 at 20:14
  • Does this answer your question? Add Windows 10 to GRUB OS list – karel Feb 19 at 21:17
  • Unfortunately no, added some more info based on what that link had though. – TheRealConner Feb 19 at 21:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.