2

I am trying to install wine on my Ubuntu 19.10. Actually, I am coming from Ubuntu 19.04, but I upgraded to 19.10 in November.

Long story short, I know of this repository which should contain everything I need to make a proper installation: deb https://dl.winehq.org/wine-builds/ubuntu/ eoan main

The problem is that when I try to do the installation apt install winehq-stable, apt throws an error and stops:

winehq-stable : Depends: wine-stable (= 5.0.0~eoan)

I have double checked if there are some old wine repositories, but there are not. I have checked for previously installed wine packages (using synaptic, searching for "wine"), and found nothing.

I have followed a few guides, but I still can't do the installation.

I am stuck in a dependency hell, but how do I find the cause?

EDIT: Wine installation on Ubuntu 19.10 is different from any previous release, because, they say, libfaudio0 was not available on Ubuntu's repositories prior to 19.10. So old questions or instructions suggesting to use external repositories are outdated.

This is what I did:

  • By following a few (outdated, but I didn't know that) guides, I have tried to install wine using old repositories. It didn't work.
    • When I have found out that Ubuntu 19.10 had different instructions I have cleaned up my sources.list, so now I don't have those old/wrong repositories anymore.
    • I have tried to manually remove every package that I have found on my system that could be related with wine.
    • At this point, I thought that my system was cleaned of all of the previous attempts. I was wrong.
  • So I have tried a new installation with the official instructions:

    sudo dpkg --add-architecture i386
    wget -nc https://dl.winehq.org/wine-builds/winehq.key
    sudo apt-key add winehq.key
    sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ eoan main'
    sudo apt install --install-recommends winehq-stable
    

And this is the complete output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
winehq-stable : Depends: wine-stable (= 5.0.0~eoan)
E: Unable to correct problems, you have held broken packages.

EDIT 2: This is my apt sources list:

/etc/apt/sources.list:deb http://it.archive.ubuntu.com/ubuntu/ eoan main restricted
/etc/apt/sources.list:deb http://it.archive.ubuntu.com/ubuntu/ eoan-updates main restricted
/etc/apt/sources.list:deb http://it.archive.ubuntu.com/ubuntu/ eoan universe
/etc/apt/sources.list:deb http://it.archive.ubuntu.com/ubuntu/ eoan-updates universe
/etc/apt/sources.list:deb http://it.archive.ubuntu.com/ubuntu/ eoan multiverse
/etc/apt/sources.list:deb http://it.archive.ubuntu.com/ubuntu/ eoan-updates multiverse
/etc/apt/sources.list:deb http://it.archive.ubuntu.com/ubuntu/ eoan-backports main restricted universe multiverse
/etc/apt/sources.list:deb http://archive.canonical.com/ubuntu eoan partner
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu eoan-security main restricted
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu eoan-security universe
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu eoan-security multiverse
/etc/apt/sources.list:deb http://it.archive.ubuntu.com/ubuntu/ eoan-proposed universe restricted main multiverse
/etc/apt/sources.list.d/google-chrome.list:deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
/etc/apt/sources.list.d/insomnia.list:deb https://dl.bintray.com/getinsomnia/Insomnia /
/etc/apt/sources.list.d/megasync.list:deb https://mega.nz/linux/MEGAsync/xUbuntu_19.04/ ./
/etc/apt/sources.list.d/nodesource.list:deb https://deb.nodesource.com/node_11.x eoan main
/etc/apt/sources.list.d/ondrej-ubuntu-php-disco.list:deb http://ppa.launchpad.net/ondrej/php/ubuntu eoan main
/etc/apt/sources.list.d/sublime-text.list:deb https://download.sublimetext.com/ apt/stable/
/etc/apt/sources.list.d/vivaldi.list:deb http://repo.vivaldi.com/stable/deb/ stable main
/etc/apt/sources.list.d/vscode.list:deb [arch=amd64] http://packages.microsoft.com/repos/vscode stable main
/etc/apt/sources.list.d/wine.list:deb https://dl.winehq.org/wine-builds/ubuntu/ eoan main
13
  • Does this answer your question? How do I restore the default repositories? as I can't reproduce your problem on clean Ubuntu 19.10 VM while following official guide from wiki.winehq.org/Ubuntu . – N0rbert Feb 18 '20 at 17:41
  • Nope. I have already checked my repositories, making sure that I had nothing that could create conflicts with the winehq repository. They are ok (I have 4-5 external repositories for other software, plus the one from winehq. – ToX 82 Feb 18 '20 at 17:45
  • The issue is probably due to something that I have installed in the past, and that is giving me dependency issues now. Maybe I've even tried -unsuccessfully- to install wine with ubuntu 19.04 and gave up (I honestly don't remember) – ToX 82 Feb 18 '20 at 17:48
  • 1
    Then you have to try to descent up to real problematic package. Try something like sudo apt-get install winehq-stable wine-stable and add complete error to the question body. – N0rbert Feb 18 '20 at 18:25
  • Apart from some italian lines, the only useful thing is winehq-stable : Dipende: wine-stable (= 5.0.0~eoan). No other packages are indicated. Do you still need the whole output? – ToX 82 Feb 18 '20 at 19:02
0

I was also having this problem and the issue for me was that, for some reason, the package libvdpau1:i386 conflicted with other packages I had (audacity, gimp, vlc, etc.).

What worked for me was to:

sudo apt install libvdpau1:i386
sudo apt install --install-recommends winehq-stable
sudo apt-get install audacity gimp vlc ... # Reinstall the packages that got removed on step 1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.