7

So I am a total noob when it comes to Linux. I finally made the switch from Windows yesterday to the latest version of Ubuntu, and I'm really happy with it aside from the gaming problems, but there are just some things I don't understand.

I'm using steam play, which is called Proton I believe? I'm using it to play Skyrim Special Edition, but none of the voice audio is coming through. All the other audio is fine and the game runs totally fine too. I went through and did all the graphics drivers and stuff, took a long time for me to figure out how to get it all to work. Still trying to figure out how to get Steam to recognize my HTC Vive VR headset, but my first benchmark for a new computer is Skyrim, so getting that to work is what I'm focused on for now.

I tried doing some research into this, but I keep seeing stuff about Wine and xact 64-bit, and forcing stuff, and how Wine and Proton don't get along but you have to run them at the same time? I am really just not understanding what the heck is going on lmao. I don't even know if Wine came installed with Ubuntu or not, but I guess it must have if I'm able to play Skyrim at all? Maybe?

Assistance would be greatly appreciated.

1
  • 2
    Yeah Upvote this would be great to know how to fix... Jul 18, 2020 at 0:59

2 Answers 2

5

Okay, i am so excited, because i searched for a long time and finally fixed this myself. Just a heads up, this might be incomplete.

To make this work, the proton "layer" requires access to some specific xaudio dll's, most notable the xaudio2_7 dll.

In here i'll condense my answer down to "what works" and try not to go to deep in to "why". First off because i would not call myself an "expert" in this topic and secondly because it is really messy and complicated. If someone want's to got in the deepend of this, feel free :)

How can you get this?

There are multiple layers to "what works" and you might find yourself satisfied earlier or later.

1

The most common fix appears to be, to install xact through winetricks (as for example discussed here, here and in many, many more parts all over the internet.

For that, you can run the following command:

WINEPREFIX=$HOME/.steam/steam/steamapps/compatdata/489830/pfx winetricks --force xact

This will (in the loostest terms possible) install the required xaudio dlls (and more) into the wine-layer used by proton.

Alternatively, you can also manually add the xaudio2_7 dll to you game, because where some crashes reported, which appears to be caused by installing the whole xact. For that run

WINEPREFIX=$HOME/.steam/steam/steamapps/compatdata/489830/pfx winecfg

and navigate to the "libraries" tab, enter "xaudio2_7", click add and you are done.

2

That didn't work? Okay, try to adjust the access level of the proton-layer. You can specify which parts the proton-layer should use, by doing the following:

run this command:

WINEPREFIX=$HOME/.steam/steam/steamapps/compatdata/489830/pfx winecfg

In the freshly opened window, navigate to the tab "libraries"

Select either *xaudio2_7 and/or xaudio2_7 and play with their access level from "Native" to "Native then Builtin". There have been multiple different positive results reported for all possible configurations.

Some even reported success with adjusting xaudio2_6 with that.

3

According to some other sources (like this issue on the proton github site itself), this does not always fix the issue.

I also found myself in this scenario. In this case, it appears that steam might override the wine access settings, which we set in 2.

This is a bit more tedious to "fix" but also can be done easily, by doing this:

  1. Rightclick your game in the steam library.
  2. Click on "Properties"
  3. Add this to the "Lauchoptions" field WINEDLLOVERRIDES="xaudio2_7=n,b" %command%

This explicitly overrides the access level of the xaudio2_7 to "Native then Builtin).

By the way: With this fix there can also finally be sound for Fallout 4 :)

Last straw

If everything else fails, try to do this (as reported here), though it should not be needed.

Download the latest FAudio build from https://github.com/Kron4ek/FAudio-Builds/releases, and untar. Then cd into the untared folder and run

WINEPREFIX=~/.steam/steam/steamapps/compatdata/489830/pfx bash wine_setup_faudio.sh

Now if you'll excuse me, I'll have 2 new games to attend to, i previously could not play because there was no dialog/sound and hopefully you will soon too :)

Have a great day everyone!

4
  • This WINEPREFIX=$HOME/.steam/steam/steamapps/compatdata/489830/pfx winetricks --force xact works fine! Thanks a lot!
    – Ivan Black
    Feb 5, 2021 at 19:37
  • Option 3 fixed the problem for me. Jul 14, 2021 at 22:02
  • PULSE_LATENCY_MSEC=60 WINEDLLOVERRIDES="xaudio2_7=n,b" %command% worked for me, thanks
    – Viktor M
    Aug 21, 2021 at 22:45
  • Thorben, bless you. Only the "last straw" option worked for me, after hours of mucking around with this problem. This is the only mention of the solution I was able to find. I will add that the compdata if you're using SKSE is 3486082390, and the fix will probably need to be applied to that ID if you're using it.
    – DDR
    Dec 30, 2022 at 4:50
0

Another possible mixture solution based on https://askubuntu.com/a/1302789/1662038 solution and https://www.protondb.com/app/72850#k9xSkVusfH solution for skyrim special edition or legendary edition:

  1. install proton 7.0-5 and skyrim via steam
  2. run on terminal

protontricks --gui

  1. select Skyrim
  2. default prefix
  3. install dll
  4. install xact_32 or xact_64
  5. run on terminal

WINEPREFIX=$HOME/.steam/steam/steamapps/compatdata/489830/pfx winetricks --force xact

  1. add on steam launchoption

WINEDLLOVERRIDES="xaudio2_7=n,b" %command%

If doesn't work try these other steps

  1. run on terminal

protontricks --gui

  1. select Skyrim
  2. default prefix
  3. install dll
  4. install FAudio
  5. run winecfg
  6. go to libraries tab
  7. set FAudio as native

Fixed on

  • OS: Ubuntu 22.04.1 LTS x86_64, CPU: Intel i7-6700HQ, GPU: NVIDIA GeForce GTX 950M

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .