12

Sorry to bother you with this, but I'm not really an expert and it may be the most stupid thing you'll see. I have ubuntu 19.04 (kernel: 5.0.0-13-generic; gcc version: 8.3.0) installed on an old pc that has a broken wifi card. So I replaced it with an external tp link wireless usb adapter. But I cannot follow the instructions:

https://static.tp-link.com/2018/201812/20181207/Installation%20Guide%20for%20Linux.pdf

I already downloaded these files and sent to the pc from another one, as it has no internet connection:

https://www.tp-link.com/en/support/download/tl-wn823n/#Driver

It may be a really stupid thing, but if I have, fe, to compile (I don't even know what it means) the driver, I don't know what it means " go to the driver directory and run the following commands ".

I really appreciate anyone and anything that helps me to solve this.

2
16
+250

If you have internet access by any other means (wired or through USB tethering), you can installed the RTL8192EU drivers for your TP-LINK TL-WN823N wireless adapter from Mange's GitHub repo. Here are the steps as described on the GitHub page:

Building and installing using DKMS

(1) Install DKMS and other required tools:

sudo apt-get install git linux-headers-generic build-essential dkms

(2) Clone this repository and change your directory to cloned path.

git clone https://github.com/Mange/rtl8192eu-linux-driver
cd rtl8192eu-linux-driver

(3) Add the driver to DKMS. This will copy the source to a system directory so that it can used to rebuild the module on kernel upgrades.

sudo dkms add .

(4) Build and install the driver.

sudo dkms install rtl8192eu/1.0

(5) Distributions based on Debian & Ubuntu have RTL8XXXU driver present & running in kernelspace. To use our RTL8192EU driver, we need to blacklist RTL8XXXU.

echo "blacklist rtl8xxxu" | sudo tee /etc/modprobe.d/rtl8xxxu.conf

(6) Force RTL8192EU Driver to be active from boot.

echo -e "8192eu\n\nloop" | sudo tee /etc/modules

(7) Newer versions of Ubuntu has weird plugging/replugging issue (Check #94). This includes weird idling issues, To fix this:

echo "options 8192eu rtw_power_mgnt=0 rtw_enusbss=0" | sudo tee /etc/modprobe.d/8192eu.conf

(8) Update changes to Grub & initramfs

sudo update-grub; sudo update-initramfs -u

(9) Reboot system to load new changes from newly generated initramfs.

systemctl reboot -i

(10) After the reboot, you can check that your kernel has loaded the right module:

sudo lshw -c network

You should see the line driver=8192eu

5
  • thank you very much in linux mint 19.3 tricia it worked perfectly ... perfect end – τασος ματσιγκας May 7 '20 at 16:16
  • Unfortunately it did not work for linux mint 20.1 Cinnamon... it says driver=r8169 and the wifi adapter does not show up as connected... – hamagust Mar 3 at 14:24
  • Thanks, it works now. I usually hesitate to install drivers from github for security reasons. I fear there might be a malicious code or sth (is that possible?) But since mange's repo is mentioned here I think it's trusted – Mido Jun 6 at 19:57
  • @mido I'm glad it worked out for you, and yes, drivers from his repo are used by many. – Jags Jun 6 at 21:15
  • I was struggling with a TP-Link TL-WN823N in Ubuntu 20.04. Worked nicely! – rasika-perera Jun 13 at 3:42
4

In addition to @Jags' comment, there is a simpler script to automate all his/her steps under the following repo.

I have validated myself on Ubuntu 20.04 and it works wonderfully.

  • Clone this repo: git clone https://github.com/clnhub/rtl8192eu-linux
  • Under the repo, run ./install_wifi.sh

Done! :)

2
  • 1
    Can confirm this worked perfectly on ubuntu 20.04.1. You can also download a zip of the repo here github.com/clnhub/rtl8192eu-linux and copy it to your machine without internet with a flash drive. – spencer.sm Sep 30 '20 at 22:04
  • Yes, working on Ubuntu 21.04, much easier than the driver installation instructions, which require editing the makefile. – apkg May 14 at 21:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.