0

After running configure of GCC 9.2.0, I get this warning:

*** This configuration is not supported in the following subdirectories:

gnattools gotools target-libada target-libhsail-rt target-libphobos target-zlib target-libgo target-libffi target-liboffloadmic

(Any other directories should still work fine.)

I do not care abaout D, ADA and GO. What perplex me are:

  • target-zlib
  • target-libffi

These warning mean that GCC will be compiled without zip and libffi support?

I'm on Lubuntu 18.04.3

  • Hopefully you mean ../gcc-9.2.0/configure --[options] -- .. drive.google.com/file/d/1DnxKV_MOGJDwZ0mDIARrooYf9kUDPQlv/… ... Please note that languages must be specified like --enable-languages=c,c++,fortran . – Knud Larsen Feb 17 at 15:24
  • @KnudLarsen I renamed the dir, and supported languages are automatically enabled, as configure assure me in output. Anywya, what about the "This configuration" message? – Marco Sulla Feb 17 at 15:33
  • I have built the most gcc versions 3.2.3 .... 9.2.0 several times drive.google.com/drive/folders/… over the last many years, and don't remember seeing a "gcc message" like yours. Can probably be avoided with a proven configure line. – Knud Larsen Feb 17 at 18:22
0

From gcc-help mailing list:

On Wed, 19 Feb 2020 at 02:33, Xi Ruoyao wrote:

Target zlib is only necessary for libphobos (which is then used by D runtime) and target libffi is only necessary for Go runtime. D and Go are not enabled by default.

Since, as I said, I'm not interested in such languages, this is not a problem :)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.