1

Problem: I can't type a capital 'C' with just shift+c.

For every other letter, the shift button works normally.
But for 'c', the only way to write a capital c is by using super+shift+c.

If I press shift+c, the xev output looks like this:

FocusOut event, serial 40, synthetic NO, window 0x3600001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 40, synthetic NO, window 0x3600001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 40, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   4   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

KeyRelease event, serial 40, synthetic NO, window 0x3600001,
    root 0x4e6, subw 0x0, time 5217617, (30,-13), root:(829,48),
    state 0x1, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

Based on another question I found, I looked for a keybinding that is grabbing this because the xev output looks like a keybinding...
But when I look under: Settings>Devices>Keyboard Shortcuts
There is no shortcut that is bound to shift+c
When I check gsettings, I see no shortcut bound to shift+c.

And I'm out of ideas. Where else can I check for keybindings?

Edit:
I have this sinking suspicion that this is the result of some attempt I made at multiboxing on this computer a few years ago and maybe this was a shortcut to switch windows.

3
  • Look at this wiki page: wiki.ubuntu.com/Keybindings – To Do Feb 16 '20 at 9:48
  • You dont' see an event for pressing the C key in your xev output? ` state 0x11, keycode 54 (keysym 0x43, C), same_screen YES,` – vanadium Feb 16 '20 at 11:28
  • Thank you for the Keybindings link. and no, I don't see that if I press shift. Not sure if it helps, but here's what I see when I press super+shift+c: ``` KeyPress event, serial 41, synthetic NO, window 0x4000001, root 0x4e6, subw 0x0, time 34057739, (-493,-262), root:(1140,90), state 0x51, keycode 54 (keysym 0x43, C), same_screen YES, XLookupString gives 1 bytes: (43) "C" XmbLookupString gives 1 bytes: (43) "C" XFilterEvent returns: False ``` – Arrrugula Feb 16 '20 at 15:48
0

The problem is most probably with your terminal shortcuts. It differs from general settings. In your terminal window, go to 'preferences' and then 'shortcuts'!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.