1

I am facing a problem with no sound from the line-out jack in Ubuntu 19.10 (running on Kernel 5.3.0). The headphones jack on the front panel works well. (see EDIT below) In the sound settings I can see that the system detects well when the speakers are connected and disconnected.

I have a dual-boot with Windows. In Windows everything works alright, so it's not a HW issue. I have also tried to shut down the computer completely before switching to Ubuntu, it did not help.

I found many similar cases online and tried the suggested solutions (such as playing with sound profiles in pavucontrol and with volume in alsamixer), however, no luck. speaker-test also does not make my speakers make a sound.

When I'm trying to test the sound using sound control in Ubuntu, after pressing a button to make a sound from one of the speakers, this appears in my syslog:

Feb 15 11:53:45 VIKING-ALES gnome-control-c[11205]: Failed to play sound: No such driver

I tried a few different versions of Ubuntu: I started with 18.04 and eventually ended up with 19.10. No sound in any version.

My motherboard is Gigabyte X570 Aorus Xtreme, the sound card is Realtek ALC1220, the details from alsa-info are here:

http://alsa-project.org/db/?f=d5c298b5a27d995fddeb2b9bad994e2eb043b058.

Any help would be highly appreciated.

EDIT: The headphones jack does NOT work well. I can hear something from it, distorted, but it's not usable.

EDIT 2: The headphones jack works well. Not sure what happened earlier.

0

TLDR:

  1. Cold-boot to Linux or change the sound driver in Windows;
  2. check you volume level for headphones in alsamixer.

To answer my own question, this behaviour seems to be caused by two different issues:

  • a collision between a Windows Realtek driver and a Linux HDA driver
  • alsamixer volume settings for headphones

After applying both of the fixes, I finally have sound from the "Line out" jack on Ubuntu 20.04 running Kernel 5.4:

ales@VIKING-ALES:~$ uname -a
Linux VIKING-ALES 5.4.0-26-generic #30-Ubuntu SMP Mon Apr 20 16:58:30 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Collision between a Windows Realtek driver and a Linux HDA driver

After digging around, I found the following thread on level1techs.com: https://forum.level1techs.com/t/has-anybody-gotten-audio-working-in-linux-on-aorus-x570-master/154072/45

As suggested there, this might be happening exclusively in the dual-boot scenario when the Linux HDA driver might not be able to initialize the sound card in a state set by the Windows Realtek driver and refuses to produce sound (even after applying the second step with alsamixer).

One solution thus is to always cold-boot to Linux. The aforementioned forum alternatively suggests to switch from the Realtek driver to a Microsoft's HDA driver. I have tried and it indeed seems to have fixed the issue. Now the reboot (with the 2nd step mentioned below) keeps the sound.

Fun fact: After switching to the Microsoft HDA driver and rebooting, Windows was not playing any sound too. I had to cold-boot to Windows to reset the state of my sound card apparently set by the Realtek driver before the reboot. So it seems that it's not only the Linux's HDA driver that has problems with recovering from the sound card state, but the Microsoft's HDA driver as well.

AlsaMixer volume settings for headphones

Another issue is that the "Headphones" volume is set to 0. Apparently, Alsa has this connected with the rear jack for speakers.

The solution is described e.g. here: No sound in Headphone from front panel audio port in Ubuntu 18.04

The only remaining issue is that the volume of the "Headphones" is not persisted across reboots or after plugging actual headphones to the front panel jack. It is another issue but when I find a solution, I might add it here for the sake of completeness.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.