1

I've been trying to connect to a VPN through my Ubuntu VPS, but every time I try, the server shuts down.

Perhaps the connection blocks the ssh, and all the traffic when I try to connect? I tried connecting with a VPN to a Dedicated Server with Ubuntu Linux, first 18.04 then 16.04, and to a virtual private server with Ubuntu Linux. Both failed, so at least I know there's no difference.

I just get disconnected and I can't connect to my VPS unless I reboot it. Is there any way I could set up a VPN on my VPS or at least is there a way to change my VPS internal IP multiple times?

So I'm using the NordVPN .deb application. After I successfully install it, I connect with my password and email, then I use ''nordvpn connect'' (sometimes I specify the server which I want to connect to, for example nordvpn connect es/br/us/etc). It says Connecting.. then the linux server just freezes, and in about 10 seconds I get disconnected.

But I didn't stop there. I tried using NordVPN manually via OpenVPN. I installed the packages, and the same thing happened, after I connected, the VPS just dropped, and I had to reboot it.

I don't have any errors to show since it's just connecting - failing - shutting down. It might also be the service I use for VPS however I'm really desperate to find a service that allows me to use VPN. I really need it for my project and In 2 attempts all failed.

Please let me know if you need further information in the comments and I will edit the question. I might have missed some things since it's pretty late, tried to work this out all day.

4
  • 1
    WhIch release of Ubuntu did you try bare metal, and in the VPS? Can you try an alternate version? – K7AAY Feb 15 '20 at 0:25
  • 1
    I tried this on Ubuntu 18.04. I'm not sure what do you mean as an alternate version. @K7AAY – Lmao 123 Feb 15 '20 at 0:30
  • 1
    Fer exx, 16.04, 19.10 – K7AAY Feb 15 '20 at 0:31
  • 1
    I have tried on 16.04 too. – Lmao 123 Feb 15 '20 at 0:33
0

the server doesn't shut down or freeze, it gets disconnected from the shh because the traffic is being forwarded from the vpn ip. I reboot multiple times my server trying to connect with a vpn on, but the vpn was starting with the system reboot. I realize that it was still possible to connect to the server using the web console of linode. I checked for the vpn service status and it was connected through US-C UDP (443). Typing:

curl http://ipinfo.io/ip

I checked for my ip. It was a different ip.

I think if you need to change VPS internal IP multiple times you could use a firewall to be able to connect to the ssh while vpn is connected, or you could use a shh script to disconnect the vpn once the task you need the new ip for is completed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.