0

So I had an old PC with Windows 10 on it. I decided I wanted to install Linux on it, as I had a few weeks ago with an old laptop which runs fine. I installed Ubuntu Server fine but then decided I wanted the version with a UI. So I installed Ubuntu via a USB it went through the process of installing until it done a restart. That's when the problem occurred. I tried to access the boot order to change it back and I couldn't access it, nor could it boot up into Ubuntu anymore. I've spent absolutely ages trying to fix this machine that runs perfectly fine but fails to get past the HP splash screen. Does Ubuntu change the way you access the BIOS or something, or have I somehow corrupt it as I absolutely cannot access it. Whenever I use any F key it leads to black screens with text as shown in the image here: https://imgur.com/a/FwR1cRf

So does anyone know a possible fix? I swear I've tried absolutely tons to fix it, yet it never gets past the HP logo or that black screen with text.

  • 2
    That black-screen-with-test shows the result of Power On Self Test (POST), which is part of BIOS. Looks like your system is not getting to the part that boots Ubuntu. Seems like you have a mis-configuration of your BIOS, or a hardware problem. Both stink, sorry, but neither seems related to Ubuntu. – user535733 Feb 14 at 22:43
  • You haven't given a release of Ubuntu, however I agree with user535733. I would boot 'live' media, check it's integrity (then let it boot again normally) and check the health of your hardware (SMART, memtest etc). I would also explore what if anything was installed (you didn't tell us what release, nor if you used a 'live' (subiquity installer) or older di (debian) installer so we don't know what options you have available on the install media (release narrows that down quite a bit). – guiverc Feb 14 at 22:51
  • Yeah, this all started when I switched the boot order to install. It worked booting Ubuntu off a USB but from there I've had absolutely no luck. You're the first to tell me what the screen actually is though, so thanks. If I can't access the BIOS though I'm not sure how I could possibly install Ubuntu, or at that boot anything from the drive already installed. Already removed the battery from the motherboard to reset it and well, it's definitely not Ubuntu itself but cannot for the life or me get this thing to load anything up nor did I have much luck trying to do a BIOS recovery with a USB – Ian Feb 14 at 22:52
  • I installed the LTS version of 18.04 from the Ubuntu website. Used Rufus to put it onto a USB. – Ian Feb 14 at 22:53
  • Ubuntu 18.04 LTS, 18.04.1, 18.04.2, 18.04.3, 18.04.3, 18.04.4, and then 'live', alternate (di) etc. you weren't specific on which you grabbed as there are multiple choices and some have limits on what hardware they can deal with (why the 'di' version has stuck around - it coped with situations the 'live' version couldn't though 'live' has improved as is now the default download for recent release). I do suspect your issue though is configuration in your BIOS as originally stated; and that is hardware specific. – guiverc Feb 15 at 0:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.