0

my /etc/ssh/ssh_config is as follows

# This is the ssh client system-wide configuration file.  See
# ssh_config(5) for more information.  This file provides defaults for
# users, and the values can be changed in per-user configuration files
# or on the command line.

# Configuration data is parsed as follows:
#  1. command line options
#  2. user-specific file
#  3. system-wide file
# Any configuration value is only changed the first time it is set.
# Thus, host-specific definitions should be at the beginning of the
# configuration file, and defaults at the end.

# Site-wide defaults for some commonly used options.  For a comprehensive
# list of available options, their meanings and defaults, please see the
# ssh_config(5) man page.

#Host *
#   ForwardAgent no
#   ForwardX11 no
#   ForwardX11Trusted yes
    PasswordAuthentication yes
#   HostbasedAuthentication no
#   GSSAPIAuthentication no
#   GSSAPIDelegateCredentials no
#   GSSAPIKeyExchange no
#   GSSAPITrustDNS no
#   BatchMode no
#   CheckHostIP yes
#   AddressFamily any
#   ConnectTimeout 0
#   StrictHostKeyChecking ask
#   IdentityFile ~/.ssh/id_rsa
#   IdentityFile ~/.ssh/id_dsa
#   IdentityFile ~/.ssh/id_ecdsa
#   IdentityFile ~/.ssh/id_ed25519
#   Port 22
#   Protocol 2
#   Ciphers aes128-ctr,aes192-ctr,aes256-ctr,aes128-cbc,3des-cbc
#   MACs hmac-md5,hmac-sha1,umac-64@openssh.com
#   EscapeChar ~
#   Tunnel no
#   TunnelDevice any:any
#   PermitLocalCommand no
#   VisualHostKey no
#   ProxyCommand ssh -q -W %h:%p gateway.example.com
#   RekeyLimit 1G 1h
#    SendEnv LANG LC_*
#    HashKnownHosts yes
#    GSSAPIAuthentication yes

my student user

ubuntu@ubuntu:~$ finger student
Login: student                  Name: 
Directory: /home/student                Shell: /bin/bash
Never logged in.
No mail.
No Plan.

when establishing an SSH connection with my VM it should as me to enter a password which isn't the case I got this ?

joseph@joseph-X541UJ:~$ multipass list 
Name                    State             IPv4             Image
ubuntu                  Running           10.226.208.153   Ubuntu 18.04 LTS
joseph@joseph-X541UJ:~$ ssh student@10.226.208.153
student@10.226.208.153: Permission denied (publickey).

why I can't log in to student user with its password please help

  • @user535733 well then do you know how to fix it and which files to configure and edit? – Yousef Saber Feb 14 at 21:05
3

You need to set this server-side. If you're unable to connect to the server at all to make these changes then you might be out of luck doing this remotely.

Try forcing password authentication first though:

ssh -o PreferredAuthentications=password -o PubkeyAuthentication=no student@<ip-address>

Once you've successfully connected through SSH you can change the server-side settings.

I suggest making a backup of the config first:

sudo cp /etc/ssh/sshd_config /etc/ssh/sshd_config.factory-defaults

Now, edit the config file:

sudo nano /etc/ssh/sshd_config

Locate the line stating PasswordAuthentication and set it to yes.

PasswordAuthentication yes

Save your file and restart SSH

sudo systemctl restart ssh

See this guide for further info on ssh configuration.

  • thank you very much I didn't notice that I've to edit my sshd_config and set PasswordAuthentication to yes I was editing the wrong file – Yousef Saber Feb 14 at 21:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.