0

Despite working properly yesterday, suddenly all Japanese text in the bookmarks, URL, tabs, web pages are rendered in a different, difficult-to-read brush-stroke Japanese font in Chromium (version 80.0.3987.100) on Ubuntu 19.10. I attempted to fix this by setting the fonts for Japanese script in the Advanced Font settings and restarting the session, but nothing has changed. (Before changing these settings, all the Japanese font settings were set to "Use default" by the way.)

Here's a screenshot of a page with Japanese text in Chromium. Notice that the fonts in the page, tab, URL, and bookmarks are displayed in the brush-stroke Japanese font. Chromium screenshot

Here's the same page in Firefox. Notice that all of the fonts in the page, tab, URL, and bookmarks are displayed in a typical Japanese gothic-type (sans) font. Firefox screenshot

Here's a screenshot of the Chromium Advanced Font Japanese font settings. Notice that the fonts are displayed correctly in the page, but not in the bookmarks. Chromium Advanced Font settings

If I change the font settings to Times New Roman, Ubuntu, or any other non-Japanese font for Japanese script, the brush-stroke font is displayed. However, if I set the default font to Noto, the problem is not solved. Chromium Advanced font settings with non-Japanese fonts

In LibreOffice fonts are displayed correctly (i.e., a brush-stroke font is not displayed in place of other fonts unless explicitly specified.) LibreOffice fonts screenshot

If I delete the brush-stroke fonts (e.g., Aoyagi Kouzan) from my Home folder and restart the session, Japanese is displayed as normal in Chromium. However, I would like to be able to use these fonts in texts occasionally.

The fact that it works in Firefox would lead one to believe that it is specific to Chromium, not Ubuntu, but at the same time, I don't have this problem in Windows, so it is possible that Chromium is using some "default" Japanese font setting from Ubuntu that I haven't been able to track down. Any ideas on how to fix this?

  • Which Ubuntu version are you on? – Gunnar Hjalmarsson Feb 14 at 1:23
  • @GunnarHjalmarsson It's Ubuntu 19.10. I also discovered that when I switch the Chromium advanced font settings for Japanese script to non-Japanese fonts, then the brush stroke appears as if AoyagiKouzan font has somehow become the default for rendering Japanese for fonts missing Japanese characters. But this only happens in Chromium. I added some more screenshots to illustrate this. – koyakun Feb 14 at 8:28
  • 2
    Is a fontconfig config file installed together with that Aoyagi Kouzan font? – Gunnar Hjalmarsson Feb 14 at 13:35
  • @GunnarHjalmarsson There's no fontconfig file in the ~.local/share/fonts/ directory where the AoyagiKouzan font is installed, but there are fontconfig files installed in ~.cache/fontconfig/, ~snap/chromium/common/.cache/fontconfig/, and ~snap/chromium/10**/.config/fontconfig/. Is there some way of opening them? Gedit says "unable to open document." – koyakun Feb 14 at 21:31
  • 2
    So you installed it in your user space... I would suggest that you uninstall that font, and instead install this package from the Ubuntu archive. – Gunnar Hjalmarsson Feb 14 at 22:03
0

This issue appears to be caused by Japanese fonts being installed in the user home directory: ~.local/share/fonts/.

To resolve it, it's necessary to delete the Japanese fonts in ~.local/share/fonts/. (To view hidden files, press Ctrl+H in the Files app.)

Japanese font packages (e.g., fonts-aoyagi-kouzan-t) installed from the Ubuntu repositories as root will not cause this issue in Chromium.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.