0

so I just installed Ubuntu 18.04 LTS on my machine today and I disconnected my HDD so I can install it on the SSD cause I was afraid to erase the HDD data, first time installing Ubuntu without a VM btw, then when I connected the HDD again I found the two partitions in /dev as /dev/sdb1 and /dev/sdb2 so I first tried running the cd command to access the HDD but it tells me that /dev/sdb1 is not a directory, then I tried copying a directory to the HDD to back it up and paste was grayed out, what can I do to access it.

Oh and I did some searching online most of the things I read said to mount the HDD using

sudo mount /dev/sdb1 /mnt/sdb1

but I get this message:

Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it 
which could be identified for example by the help of the 'fuser' command.

The output of the mount | grep sdb command was

/dev/sdb1 on /media/ali/01D3FD2314DE1DE0 type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)
/dev/sdb2 on /media/ali/01D3FD23187F1260 type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)
  • Could you add to your question the output of mount | grep sdb. This will show the mount options. – stark Feb 13 at 20:49
  • Try the command mount -o remount,rw /dev/sdb1 – stark Feb 13 at 21:21
1

The /dev/ files are hardware device nodes. Best not to mess with those.

To see the disk, use the df command (display filesystems). Output will be like:

 df
Filesystem       1K-blocks        Used   Available Use% Mounted on
udev               8144388          12     8144376   1% /dev
tmpfs              1631076        1008     1630068   1% /run
/dev/sda1         61414412    24208268    34456664  42% /
none                     4           0           4   0% /sys/fs/cgroup
none                  5120           0        5120   0% /run/lock
none               8155372       80440     8074932   1% /run/shm
none                102400          60      102340   1% /run/user

Note that I have /dev/sda1 mounted as my root filesystem.
The message that you are getting suggests that /dev/sdb1 is already mounted. See if it shows up with df.

  • the two partitions showed up as /dev/sdb1 976751968 914130100 62621868 94% /media/ali/01D3FD2314DE1DE0 /dev/sdb2 976760032 933519308 43240724 96% /media/ali/01D3FD23187F1260 using the df command, and I can now cd into them using the path after the percentage of the partition, but when I tried copying a file to a partition I got this message: cp: cannot create directory '/media/ali/01D3FD23187F1260/Acres and Karats Calculator': Read-only file system – Ali Mohamed Feb 13 at 20:33
  • btw I forgot to mention I had my hard drive partitioned on windows 10 before, IDK if that will make any difference – Ali Mohamed Feb 13 at 20:35
  • Could you take a look at this question? askubuntu.com/a/70304/1030912 – stark Feb 13 at 20:38
  • I tried everything in that question and still can't copy – Ali Mohamed Feb 13 at 20:46
  • ok so I kinda fixed it and ruined it at the same time, I unmounted both partitions in file manager then mounted /dev/sdb1 to /mnt/sdb1, then I mounted /dev/sdb1 to /mnt/sdb1 too by mistake, and now I can't find the partition sdb1 and I think I overwrote it, but it doesn't matter it only had steam games, I just wanna get that partition back – Ali Mohamed Feb 13 at 21:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.