0

I have setup an ubuntu server with a web server i want to port-forward. I tried accessing the IP over proxy and it worked. I have set a dyndns and over a web proxy this worked too. But when i type it in in the same network as the server, it tells me that the Server is unreachable. How can i fix this?

  • I hope this is not Off-topic here, if so, tell pls tell where to post it – Niwla23 Feb 13 at 14:34
2

You are trying to create a NAT loopback from your WAN IP. You want to use your internal IP from the LAN side. As it stands your router either does not support NAT loopback, or if it does, it is not enabled. You can search google for your router model and "NAT loopback" to see if it supports it and if so how to configure.

If it doesn't, your other option is to create an internal DNS server, add the dyndns domain and host record, and make it your "first" DNS server in your network interface settings. This way it will still work outside of the network, just make sure your ttl is relatively short on the DNS record so you are not using cached records outside. Make sure you configure forwarders on your internal DNS server to your usual DNS server, so that you resolve external domains.

I do this myself as I use my domain both internally and externally. My router does support loopback, but I already have Active Directory domain controllers with DNS, so I went that route.

Edit: My assumption was you were not trying to browse it from the server, but rather a laptop that you moved around with. My answer might have been a bit too complex for your needs.

  • See my answer, I fixed it now, but thanks anyways – Niwla23 Feb 15 at 16:10
-1

I found out how to do it now:

You have to change nameserver in /etc/resolv.conf to 1.1.1.1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.