I am using Ubuntu virtual host to run a tomcat based application that uses the port 8080, 8009, and 8000. The network admin has already opened the ports and when I run nmap on localhost it shows that they are opened.

$ nmap localhost

Starting Nmap 7.60 ( https://nmap.org ) at 2020-02-10 12:46 UTC
Nmap scan report for localhost (
Host is up (0.00023s latency).
Not shown: 995 closed ports
22/tcp   open  ssh
80/tcp   open  http
3306/tcp open  mysql
8009/tcp open  ajp13
8080/tcp open  http-proxy

However, running nmap on from my machine, using the IP address shows me they are filtered.

$ nmap 120.xxx.xxx.xxx -p 8080

Starting Nmap 7.60 ( https://nmap.org ) at 2020-02-12 10:36 EAT
Nmap scan report for
Host is up (0.17s latency).

8080/tcp filtered http-proxy

Nmap done: 1 IP address (1 host up) scanned in 2.39 seconds

I don't have access to the azure interface, and there is no firewall enabled on the ubuntu vm.

What could be filtering the request? What can I do?

  • Did you intend to hide your IP address in the question? Nmap happily reports it back to you. – Jos Feb 12 at 8:15
  • What do you get if you run nmap on the public IP, but from the computer itself? – Gordon Davisson Feb 12 at 8:23
  • @Jos I guess it did :) anyways it's public IP and I don't have to hid it – altsyset Feb 12 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.