0

I have recently installed 6 Ubuntu Server 18.04.3 VMs to test a private blockchain network. I use Hyperledger Besu as my ethereum client to do the same. However, there have been some issues lately that I cannot seem to resolve. I use the default terminal interface to operate the system, and a lot of times the output is longer than the screen and it automatically scrolls down. I used to pipe the output by using 'less', but in the case of using the besu command, when an error comes up, 'less' seems to malfunction and I cannot scroll up.

Is there any way or deb that I can install that will enable scrolling in my Ubuntu Server VM?

(Please note that I have already tried all the usual key bindings of Ubuntu like Shift+PgUp and Shift+PgDown and others like Ctrl+Shift+Up and Ctrl+Shift+Down).

New contributor
hunterkiller1441 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • "I use the default terminal interface". On what system? Your server is not the issue. It is the client terminal software used. Generally terminal interfaces have an option to increase the "buffer" or "lines of scrollback" (putty uses that kind of wording). – Rinzwind Feb 12 at 7:50
0

While I'm not familiar with besu enough to point out why | less won't work, I may still suggest the good old way of command output redirection to a file, and cat its content with formatting of your choice.

'MyCommand' > 'SomeFile'

This also may help you document multiple outputs of that command for further analysis when repeating manually or scripting.

  • I tried the output redirection, but for some reason it just displayed lines just containing '~' instead of the output. – hunterkiller1441 Feb 13 at 5:29
  • Is that the same output you see in the ubuntu server cli when using 'less'? Did you try your command with 'less' option? (there is no need for 'less'). Are you using cat to display the contents of the file? What do you see when opening the new file with vim/nano? You also might want to try doing append to existing files (using '>>' parameter). A single '~' may indicate an empty file, or non existing file (yet) when using an editor, and you get the option to create one. – GrumpyBurger Feb 13 at 9:44

Your Answer

hunterkiller1441 is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.