3

I encrypted the hard disk with LUKS.

When I boot the PC, the screen says: please unlock disk sda5_crypt.

Is it possible to return to this screen from the command-line? If the PC can return from the unlocked state, it is OK even if not from the command-line. Is restarting my PC the only way to fix this problem?

I executed the command $ lsblk -a and I paste the output.

NAME                   MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
loop0                    7:0    0  88.5M  1 loop  /snap/core/7270
loop1                    7:1    0 160.2M  1 loop  /snap/gnome-3-28-1804/116
loop2                    7:2    0  54.7M  1 loop  /snap/core18/1650
loop3                    7:3    0  89.1M  1 loop  /snap/core/8268
loop4                    7:4    0  44.9M  1 loop  /snap/gtk-common-themes/1440
loop5                    7:5    0   4.2M  1 loop  /snap/gnome-calculator/544
loop6                    7:6    0  54.7M  1 loop  /snap/core18/1668
loop7                    7:7    0  14.8M  1 loop  /snap/gnome-characters/399
loop8                    7:8    0  42.8M  1 loop  /snap/gtk-common-themes/1313
loop9                    7:9    0  14.8M  1 loop  /snap/gnome-characters/375
loop10                   7:10   0   3.7M  1 loop  /snap/gnome-system-monitor/123
loop11                   7:11   0   3.7M  1 loop  /snap/gnome-system-monitor/127
loop12                   7:12   0     4M  1 loop  /snap/gnome-calculator/406
loop13                   7:13   0   956K  1 loop  /snap/gnome-logs/81
loop14                   7:14   0  1008K  1 loop  /snap/gnome-logs/61
loop15                   7:15   0 156.7M  1 loop  /snap/gnome-3-28-1804/110
loop16                   7:16   0         0 loop  
sda                      8:0    0 465.8G  0 disk  
├─sda1                   8:1    0   512M  0 part  /boot/efi
├─sda2                   8:2    0   732M  0 part  /boot
└─sda3                   8:3    0 464.6G  0 part  
  └─sda3_crypt         253:0    0 464.6G  0 crypt 
    ├─ubuntu--vg-root  253:1    0 463.6G  0 lvm   /
    └─ubuntu--vg-swap_1
                       253:2    0   980M  0 lvm   [SWAP]

Screenshots of Disks with detailed info for each partition

Add
Thank you for answering!
I tried the command, but I got the following error.
Failed to hibernate system via logind: Sleep verb not supported
I did a search and it said that disabling secure boot is the solution.
Althought I tried, it didn't work.
At first, I seem to have to solve the problem of hibernating ubuntu 18.04...

1
  • 1
    I don't see any sda5_crypt. I only see sda3_crypt. Is there a sda5_crypt that does not show up in the lsblk -a output? If so, can you open the app "Disks" and select the sda5_crypt in there and take a screenshot? Add the screenshot in your question. – user68186 Feb 11 '20 at 20:14
0

The closest thing that I know of is to hibernate the system. Try the following command:

sudo systemctl hibernate

Personally I have one PC that this fails to work on (system restarts as if shut down) and another where this works.

If your system can successfully hibernate, then you'll arrive at the password prompt when you turn it back on, and then the system will start where you left off.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.