0

I have bought the Canonical certified DELL Inspiron 15 3585 and i have an issue with audio playback. It only happens when using built-in speakers, it doesn't happen on playback through the 3.5 mm jack output or HDMI output.

I already tried disabling power save

$ cat /sys/module/snd_hda_intel/parameters/power_save
0

$ cat /sys/module/snd_hda_intel/parameters/power_save_controller 
N

i also tried tsched=0 and using aplay /dev/zero, nothing helped thus far

additional info:

$ lspci | grep Audio
04:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio Controller
04:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) HD Audio Controller

$ dmesg | grep -i error
[    1.065246] tpm_crb: probe of MSFT0101:00 failed with error -16
[    1.119343] RAS: Correctable Errors collector initialized.
[    8.980071] EXT4-fs (dm-1): re-mounted. Opts: errors=remount-ro
[    9.769684] pcieport 0000:00:01.7: AER: Multiple Corrected error received: 0000:00:01.0
[    9.769697] pcieport 0000:00:01.7: AER: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Receiver ID)
[    9.769702] pcieport 0000:00:01.7: AER:   device [1022:15d3] error status/mask=00000040/00006000
[   11.691398] pcieport 0000:00:01.7: AER: Multiple Corrected error received: 0000:00:01.0
[   11.691419] pcieport 0000:00:01.7: AER: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Receiver ID)
[   11.691425] pcieport 0000:00:01.7: AER:   device [1022:15d3] error status/mask=00000040/00006000
[   11.727149] pcieport 0000:00:01.7: AER: Corrected error received: 0000:00:01.0
[   11.727159] pcieport 0000:00:01.7: AER: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Receiver ID)
[   11.727164] pcieport 0000:00:01.7: AER:   device [1022:15d3] error status/mask=00000040/00006000


$ dmesg | grep -i audio
[    0.565377] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[    9.843973] snd_hda_intel 0000:04:00.1: Handle vga_switcheroo audio client
[    9.855036] input: HD-Audio Generic HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:08.1/0000:04:00.1/sound/card0/input16
[    9.905946] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC3234: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[    9.905950] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    9.905952] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    9.905954] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[    9.905955] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[    9.905958] snd_hda_codec_realtek hdaudioC1D0:      Headset Mic=0x19
[    9.905960] snd_hda_codec_realtek hdaudioC1D0:      Headphone Mic=0x1a
[    9.905961] snd_hda_codec_realtek hdaudioC1D0:      Internal Mic=0x12
[    9.963314] input: HD-Audio Generic Headphone Mic as /devices/pci0000:00/0000:00:08.1/0000:04:00.6/sound/card1/input18

OS: Kubuntu 19.10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.