1

I have installed server 19.10 and the did the following:

  • sudo apt update
  • sudo apt upgrade

  • Then I did a reboot

  • I then did

    sudo apt-get install ubuntu-desktop

All seems to go well

  • Then I confirmed that there were no additional updates...

  • Then I did a reboot

The system came up well.. and all seems to be great...

But.. Things like the settings option can not see the network and the software program to download programs can not see the network and suggests me look at the network setting..

The network interface is now seen with ip a and is no longer eth0 but follows a new standard...

Is there a new updated ubuntu-desktop package to install???

To save the question .. why install the server and then the desktop when the desktop version of ubuntu 19.10 works great!! I am planning to install UBUNTU 19.10 on my Raspberry PI 4 and want the desktop experience... I am testing the install on my faster PC..

Any insight would be helpful

Further to questions: - cat /etc/netplan/*.yaml

network:
  version: 2
  renderer: NetworkManager
  ethernets:
    enp0s3:
      match:
        name: enp0s3
      set-name: eth0
      dhcp4: yes
# This file is generated from information provided by
# the datasource.  Changes to it will not persist across an instance.
# To disable cloud-init's network configuration capabilities, write a file
# /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg with the following:
# network: {config: disabled}
network:
    ethernets:
        enp0s3:
            dhcp4: true
    version: 2
  • sudo lshw -class network
  *-network                 
       description: Ethernet interface
       product: 82540EM Gigabit Ethernet Controller
       vendor: Intel Corporation
       physical id: 3
       bus info: pci@0000:00:03.0
       logical name: enp0s3
       version: 02
       serial: 08:00:27:e1:30:c6
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 66MHz
       capabilities: pm pcix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000 driverversion=7.3.21-k8-NAPI duplex=full ip=192.168.1.54 latency=64 link=yes mingnt=255 multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:19 memory:f8200000-f821ffff ioport:d020(size=8)
  • Your question is not clear. Why did you install the server version when it sounds like you wanted the desktop version? In the server version, you have to edit /etc/netplan/*.yaml file to make the network work. – heynnema Feb 10 at 2:12
  • There is only a server version for the install on the Raspberry PI 4. So I plan to install the server version and then add the desktop to let me use the GUI experience – fred flintston Feb 10 at 2:14
  • I have tried to edit the .yaml file.. I am having problems setting the logical name of the ethernet device as eth0 as it used to be... – fred flintston Feb 10 at 2:17
  • Ok, edit your question and show me cat /etc/netplan/*.yaml and sudo lshw -C network. – heynnema Feb 10 at 2:17
  • I figured out how to add the answers into the original question.. It is more readable – fred flintston Feb 10 at 2:51
1

Your .yaml file is wrong, because you mix NetworkManager and networkd syntax.

The following two .yaml files are for a pure server installation... no Desktop, no GUI.

Your .yaml file should look like this...

network:
  version: 2
  renderer: networkd
  ethernets:
    enp0s3:
      dhcp4: true

And if you REALLY want to use eth0:

sudo pico /etc/default/grub or sudo -H gedit /etc/default/grub

Search for "quiet splash" and change it to "quiet splash net.ifnames=0"

sudo update-grub

And then use this .yaml...

network:
  version: 2
  renderer: networkd
  ethernets:
    eth0:
      dhcp4: true

Then...

sudo netplan --debug generate

sudo netplan apply

reboot


Update #1:

If you decide to use NetworkManager, and the GUI to setup your network, then you need this .yaml...

network:
  version: 2
  renderer: NetworkManager

Remember to always use the sudo netplan... commands that I gave earlier.

  • I saw the comment to disable cloud-init in the original post..I did as it suggested. I rebooted and the network symbol appeared and all the utilities can work with the network... I removed the disable and rebooted.. network symbol stayed. I tried your first .yaml file and applied it and the network symbol went away. put my original .yaml file and the symbol came back.. I agree going back to the eth0 is a poor choice as it eventually will disapear. I wonder if the desktop utilities need the render to be NetworkManager? – fred flintston Feb 10 at 6:20
  • @fredflintston Please see Update #1 in my answer. – heynnema Feb 10 at 13:33
  • @fredflintston Edit your question and show me ls -al /etc/systemd/network. – heynnema Feb 10 at 13:34
  • Just to be really sure... I am going to start from scratch with the server.. then the desktop.. then doing the netplan and see without disabling cloud-init... Looking good.. and thanks to you learning a lot.. (thanks) – fred flintston Feb 10 at 22:03
  • @fredflintston I saw your comments that were an edit to my answer. It sounds like my Update #1 solved your problem. Please don't edit my answer, but rather, place them as comments, fair enough? Accept the answer if it made a difference. Thanks! – heynnema Feb 10 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.