0

I was waiting for official instructions on ubuntu.com for installing Ubuntu LTS on my Raspberry Pi 4 (4GB edition). Since a few days there is a new site/downloads with official support for the Raspberry Pi 4 (Ubuntu Server 18.04.3 LTS and Ubuntu Server 19.10; 64- and 32-bit) and appropriate instructions.

I tried to install Ubuntu Server 18.04.3 LTS (64-bit) on a 64GB SanDisk Ultra Class 10 micro SD card as instructed after the download:

  1. What you’ll need... (including "A Raspberry Pi 2, 3, or 4")
  2. Flash Ubuntu onto your microSD card... (using Windows with Win32DiskImager)
  3. Boot Ubuntu Server...
  4. Login to your Pi...

Unfortunately Step 3 is not working: Only the red LED on my Raspberry lights up constantly (using 3A/15W USB-C-power-supply). I waited over 10 minutes - to not avail.
Setup: Only a VGA-Display is connected to the HDMI0-Port via microHDMI -> HDMI and HDMI -> VGA adapters. Raspbian Buster is working without any problems.

Thanks for your support!

  • 1
    On a pi 4, replacement 19.10.1 images were spun up to resolve an issue, so use 19.10.1 not 19.10 (the download page still says 19.10 but will provide 19.10.1 if you're downloading the pi 4 version which you can note by filename). Step 3 failing probably means a failure on the prior step(s), the latest tutorial for step 2 is discourse.ubuntu.com/t/… – guiverc Feb 8 at 22:01
0

Have you checked the firmware upgrade for the pi4 before trying to install the official 18.04.3 version. see https://jamesachambers.com/raspberry-pi-ubuntu-server-18-04-2-installation-guide/.

I don't understand why my previous post (see text above) was deleted. The link provided, clearly documents that in order to boot 64bit ubuntu server, you need to upgrade the firmware. The link provides instructions for the firmware upgrade. I am running 2 pi4 with unofficial ubuntu server 18.04.2 using this method and they have been working perfectly. I have 2 additional ones on order and will use this method to install official 18.04.3.

Happy to not contribute at all if the help provided in my comments isn't considered appropriate.

New contributor
gavin is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
0

My new PI4's arrived, so I did a test. The official distribution 18.04.3 (64bit) would not boot on the pi4, as you described. I then booted raspian on a separate sdcard and executed the command sudo apt install rpi-eeprom and rebooted. Changed the sdcard over to the standard 18.04.3(64bit) and tried to boot again. It still didn't work. Next I followed the instructions from https://jamesachambers.com/raspberry-pi-ubuntu-server-18-04-2-installation-guide/. Mount the sd card with 18.04.3 on another linux system. Looked at the boot partition. Edited the config.txt file and added the follow to the bottom of the file. The pi4 then booted the official distribution without a problem. Not sure if both steps are required or it is just the change in the config.txt file. But it works fine now.

dtparam=audio=on

[pi4]

arm_64bit=1

enable_gic=1

armstub=armstub8-gic.bin

[all]

New contributor
gavin is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.