1

I am running Ubuntu 18.04 LTS on my home laptop (server) and Windows 10 laptop with WLS running Ubuntu (client) but I do not have physical access to my home laptop at the moment.

Until recently I was able to connect to my home server and run some programmes on it. To achieve this I used an SSH connection then used tmux according to this answer.

This was working fine until my Window 10 laptop 'slept' with the tmux terminal open.

Now when trying to SSH into my home computer I get the 'Resource temporarily unavailable' error. I'm also unable to ping it either as I get 100% packet loss.

The output the the w command does not show any connections.

I have also tried following this answer on the client but I still can't connect to the server.

How can I fix this and use SSH to connect to my home computer just like before?

Note: I had a similar problem (ssh: resource temporarily unavailable) when I first tried to use SSH but fixed it by setting up port forwarding in my router at home.

Update

I added the following to the end of my /etc/ssh/ssh_config file based on this post:

Host *
    ProxyCommand nc %h %p %r

And now the error I get is ssh_exchange_identification: Connection closed by remote host

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.