2

So my new system (Threadripper 3970x on Gigabyte TRX40 AORUS MASTER) doesn't boot on Ubuntu 19.10 - it gets stuck at recognizing USB devices:

7-6 New USB device found, idVendor=05e3, idProduct=0608
7-6 New USB device strings: Mfr=0, Product=1, Serialnumber.....
7-6 Product: USB2.0 Hub
7-6:1.0: USB hub found
7-6:1.0: 4 ports detected

..then nothing happens. This is the same on booting from USB stick, normal boot and recovery mode.

I tried removing USB devices, but this hub seems to be on the motherboard. What can I do? Since I can't even enter recovery mode it seems a bit tricky to troubleshoot. Can I disable specific USB ports through GRUB maybe? Or is the listed USB entry not even the problem?

1
  • Now I tried Ubuntu 18.04 (already had it on a stick). Indeed, this one boots successfully - it just reports some UEFI issues. So, any ideas on how to fix the 19.10 installation? Or do I need to make a full reinstall?
    – Warner
    Feb 8, 2020 at 14:52

1 Answer 1

2

You need to add an mce=off line to your kernel parameters if you wish you use kernel version 5.39 - the default kernel for Ubuntu 19.10.

See: https://www.phoronix.com/scan.php?page=news_item&px=Linux-Boot-Threadripper-Zen2MCE

I edited my grub config by booting into Ubuntu with the 4.15 Kernel as found in my grub menu and then using grub-customizer to add the parameter.

1
  • Yes! Simply adding mce=off as a parameter in GRUB solved the problem. Thanks so much for your help!
    – Warner
    Feb 15, 2020 at 13:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .