1

When I install WMWare tools, I get this error for vmhgfs:

/tmp/vmware-root/modules/vmhgfs-only/filesystem.c:47:28: fatal error: linux/smp_lock.h: No such file or directory
compilation terminated.
compilation terminated.
make[2]: *** [/tmp/vmware-root/modules/vmhgfs-only/filesystem.o] Error 1
make[1]: *** [_module_/tmp/vmware-root/modules/vmhgfs-only] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.0.0-12-generic'
make: *** [vmhgfs.ko] Error 2
make: Leaving directory `/tmp/vmware-root/modules/vmhgfs-only'
If you wish to have the shared folders feature, you can install the driver by 
running vmware-config-tools.pl again after making sure that gcc, binutils, make
and the kernel sources for your running kernel are installed on your machine. 
These packages are available on your distribution's installation CD.

And /mnt/hgfs is empty when sharing. If I run vmware-hgfsclient in a terminal, I get the list of shared folders but /mnt/hgfs is empty.

i try to new version of vmware tools with vm machin but it very slowly And during the download is interrupted. can you give me link for tar.gz file?

  • Did you installed the kernel header for your running one ? – daisy Apr 11 '12 at 0:24
1

I download this version:

VMwareTools-8.8.0-471268.tar.gz

The problem was solved

  • Yeah right, but how/where exactly did you get/download VMwareTools-8.8.0-471268.tar.gz!?? :( Just spent couple of hours looking for it and couldnt find anywhere... Any link would be of great help! Thx. – user54527 Apr 11 '12 at 21:47
0

You can find the previous versions here: http://softwareupdate.vmware.com/cds/vmw-desktop/player/

This blog has some details on what to do if you are running VMware on a Windows host: http://pete.akeo.ie/2011/11/using-older-versions-of-vmware-tools.html

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.