EDIT: Optimus card. For resolution please read this thread:

"You do not appear to be using the nvidia x server"(screenshot included)

And this:

Ubuntu 11.10 problem with Nvidia


I know, I know yet another NVIDIA question.

So I did all the research. I uninstalled and installed nvidia-settings and drivers and nvidia-current from PPE repositories which are the most updated ones.

I executed nvidia-xconfig.

I have two major problems.


Additional Drivers setting is empty! It doesn't contain any driver although one is installed. I have executed apt-get update too. But still the list is empty.


If I execute nvidia-xconfig it will properly configure an xorg.conf file. I restart but the maximum resolution I got is 640x480. I tried the xrandr but I can't add any resolution to display LVDS1. Some weird error occurs.

So I can't add a proprietary driver and I can't boot in with the xorg file created by Nvidia...

What can I do? With some work ( unistall nvidia-current and install libgl1-mesa-glx I was able to activate some kind of usage of my card because the resolution got better... and I added bumbelbee to because I have multiple video cards... ) but still the list is empty. I don't know what to do at this point??!!!


this is the most important part. When I first installed my ubuntu yesterday 11.10 one I saw the driver!! The driver was there... And then I ofc updated every package from internet.. And after that it was gone. And I can't bring it back. So there must be something wrong with one of the updates. But which????

Thanks for any extra info you can provide! I'm really desperate to solve this issue.

2 Answers 2


Does your Laptop provide Nvidia Optimus Technology? If you have Nvidia Optimus technology in your laptop, you have, according to the Project Bumblebee FAQ, two options:

1) Check your system bios for an option to permanently switch to your nvidia graphics card

2) If your bios does not provide this feature you can use a solution named bumblebee. You can find all necessary background information about nvidia optimus technology and bumblebee project here. if you want to use bumblebee, you find the installation routine here.

Hope this helps


You did not mention your graphics card model number and details. Follow the steps to get rid of the situation.

  1. Start ubuntu with recovery mode. Login in root shell (with networking)
  2. Remove your nvidia driver(what you did install)
  3. maybe this can be help: sudo apt-get purge nvidia-current sudo rm -rf /etc/X11/xorg.conf
  4. restart your computer: sudo reboot
  5. start ubuntu normally (not recovery)
  6. open /etc/default/grub : sudo gedit /etc/default/grub
  7. replace the line GRUB_CMDLINE_LINUX="" to GRUB_CMDLINE_LINUX="nomodeset" (save and exit)
  8. update grub: sudo update-grub
  9. Download appropriate driver from here [better to save the file in home folder] 10.Give executable permission to the downloaded file : chmod a+x nvidia_driver.sh
  10. Press CLT+ALT+F1 [command line shell will appear] and login
  11. stop lightdm service : sudo service lightdm stop
  12. start nvidia installation: sudo ./nvidia_driver.sh
  13. reboot your system: sudo reboot
  • Okay, I will try. Sorry, yeah it's an nvidia geforce m525.
    – Hannibal
    Apr 10, 2012 at 22:05
  • It didn't work man... It says after I log to root: W: Not using locking for read only lock file /var/lib/dpkg/lock. E: Unable to write to /var/cach/apt/. E:The package lists or status file could not be parsed or opened. This is after I execute apt-get purge, or apt-get remove --purge.
    – Hannibal
    Apr 10, 2012 at 22:15
  • BTW. I tried not using SUDO since I was already a ROOT... Didn't help.
    – Hannibal
    Apr 10, 2012 at 22:17
  • there should be a fsck option(root shell entering option). select that one first, it will unlock your drive access.
    – shantanu
    Apr 10, 2012 at 22:21
  • Ok, so that helped, but... installed failed because: I don't have an nvidia GPU ( LOL ) 2: could not find nvidia.ko. So could not build the stuff.. :S
    – Hannibal
    Apr 10, 2012 at 22:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.