0

I recently updated some packages, and I'm getting an error on reboot saying the hardware acceleration has been disabled, and the package manager doesn't work any more.

The error messages keep mentioning "libegl-mesa0", so I tried to remove them, but I get told to use sudo apt --fix-broken install, but when I try that, I get this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libegl-mesa0 libegl-mesa0:i386
The following NEW packages will be installed
  libegl-mesa0 libegl-mesa0:i386
0 to upgrade, 2 to newly install, 0 to remove and 9 not to upgrade.
Need to get 0 B/300 kB of archives.
After this operation, 698 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Selecting previously unselected package libegl-mesa0:amd64.
(Reading database ... 312876 files and directories currently installed.)
Preparing to unpack .../libegl-mesa0_20.1~git2002041930.b06469~oibaf~b_amd64.deb ...
Unpacking libegl-mesa0:amd64 (20.1~git2002041930.b06469~oibaf~b) ...
Selecting previously unselected package libegl-mesa0:i386.
Preparing to unpack .../libegl-mesa0_20.1~git2002041930.b06469~oibaf~b_i386.deb ...
Unpacking libegl-mesa0:i386 (20.1~git2002041930.b06469~oibaf~b) ...
dpkg: error processing archive /var/cache/apt/archives/libegl-mesa0_20.1~git2002041930.b06469~oibaf~b_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/glvnd/egl_vendor.d/50_mesa.json', which is different from other instances of package libegl-mesa0:i386
Errors were encountered while processing:
 /var/cache/apt/archives/libegl-mesa0_20.1~git2002041930.b06469~oibaf~b_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I also tried sudo dpkg --force depends -P libegl-mesa0, and I get this output:

dpkg: libegl-mesa0:amd64: dependency problems, but removing anyway as you requested:
 libegl1:amd64 depends on libegl-mesa0.

(Reading database ... 312884 files and directories currently installed.)
Removing libegl-mesa0:amd64 (20.1~git2002041930.b06469~oibaf~b) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...

I don't know if this did anything, and it didn't fix the problem above.

What do I do?

I'm using an AMD GPU (R9 Fury, to be exact), if that helps.

1

I solved the issue.

I went onto recovery mode, and used fix broken packages options and apt-get clean.

It then reboot without a graphics driver, then I reinstalled them, and it all works again!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.